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LESSON - 1

INTRODUCTION TO WORKSHEET AND EXCEL

1.0 OBJECTIVE :

In this lesson we shall discuss

1. An Electronic Spread Sheet (Work Sheet)

2. Advantages of using an Electronic Spread Sheet

3. What is Excel ?

STRUCTURE :

1.1 INTRODUCTION

1.2 APPLICATIONS OF AN ELECTRONIC WORKSHEET

1.3 FEATURES OF AN ELECTRONIC WORKSHEET

1.4 WHAT IS EXCEL

1.5 STARTING EXCEL / GETTING STARTED

1.6 EXCEL SCREEN

1.7 SUMMARY

1.8 SELF ASSESSMENT QUESTIONS

1.9 REFERENCE BOOKS.

1.1 INTRODUCTION :

An electronic worksheet or (spread sheet) is used to store information in the memory of a
computer. In such a worksheet, information is entered through the key board and displayed on the
computer screen. In other words, it replaces the normal paper sheet or ledger, paper or pen, eraser
and calculator. The information already entered on the screen can be changed very easily. The
worksheet calculates results for instance, it can calculate the total sales by multiplying the quantity
sold with unit price. If any information is changed, the worksheet program automatically recalcu-
lates all the results. For instance if the unit price changes it will immediately recalculate and display
the new total sales value. The worksheet program can also display the results in the form of graphs.
The information entered in the worksheet can also be printed.

1.2 APPLICATIONS OF AN ELECTRONIC WORK SHEET :

You can also store all kinds of information in the spread sheet. Some common applications of
a spread sheet are in the following areas.

- Annual reports of business firms

- Income statement and income tax calculations

- Payrolls

- Invoicing (Billing)

- Accounts payable and receivable
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- Production and Marketing analysis

- Investment and loan analysis

- Banking and other financial services

- Inventory control

- Tender evaluation

- Scientific calculations

- Cost-effective analysis.

1.3 FEATURES OF AN ELECTRONIC WORK SHEET :

The electronic worksheet generally offers the following features too.

- The results are accurate

- The worksheet can be quite big in size and any part of it can be viewed or edited.

- Data entered in a work sheet can be formatted in several ways to give it a professional
look.

- Several mathematically, trignometric, financial and statistical functions are built in. All sorts
of complicated calculations can be performed using these functions, facilitating rapid
operations.

- Data can also be viewed in the form of graphs. These graphs which can be of various
types, can be printed.

- The worksheet is saved in an electronic file. The file can retrieved and modified later, if
required.

- An existing worksheet or any part of it can be merged with any existing of new worksheet.

- The information entered in a worksheet can be stored in a desired format.

- With an electronic worksheet program, you can easily and quickly produce reports and
get answers to what-if questions.

- The information stored in a worksheet can be transformed to other software programmes
such as word, wordstar, Foxpro, dBase etc. Similarly information stored in other soft-
ware programs can also be transferred to a work sheet.

1.4 WHAT IS EXCEL ?

Excel is an integrated electronic worksheet (spread sheet) program developed by Micro soft
corporation, USA. It includes three components - worksheet, graph (chart) and database manage-
ment. It lets you create your worksheet and enter information. It performs all kinds of calculations
and displays results on the screen in the form of figures or graphs. You can perform various data
base management functions on the data entered in the worksheet. A few other important features
of Excel are :

- Date and time-related functions

- Manipulation of character data (string)

- Data base management

- Keyboard macros to automate tasks

- Drawing toolbar to create graphics
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- Each work sheet can have multiple sheets.

1.5 STARTING EXCEL / GETTING STARTED :

The obvious way to start Excel is to choose it from the start submenu or you can click the
Excel icon in the office short cut bar. You can also double click the Excel Icon in the office short cut
Bar. You can also double click the Excel icon in windows explorer starting in any of these ways
opens a new untitled workbook. You can also start Excel by double clicking Excel worksheet icons
and related files. This starts the program.

1.6 THE EXCEL SCREEN :

When you start Excel, it automatically creates a new work sheet- Book I. Notice that it is
displaying the name of the program (Microsoft Excel) and the worksheet (Book I) in the title bar of
the window.

The next line of Excel window is called the menu bar. The menubar is used to select various
commands available in Excel. The Excel menu system is divided in to nine categories. Accordingly,
the menu bar contains nine menu items. Each menu item opens a different menu.

In the above figure there are two bars below the menu bar. These bars are called tool bars.
Each tool bar contains a few buttons. Tool bars provides an alternate way of choosing commands.

The next line below the toolbar is called the formula bar. Excel uses the formula bar for
displaying information, such as the address of the active (current) cell, contents or formula entered
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in the current cell etc.

The area below the formula bar that occupies most part of the Excel window is called the
work space or worksheet area. This area is used to enter information (data) in your worksheet. You
will also enter formulas in this area and Excel displays the calculated results in place of formulas.
You also use this area to displays graphs. The work space area is a grid of rows and columns. The
workspace area has a border on the top and left side. This border is called the worksheet frame.
Notice that there are column letters 1,2,3 etc and row numbers A,B,C etc in the worksheet border.
The letters along the top border designate columns and the numbers along the side border desig-
nate rows. On the bottom left part of the worksheet frame, you find the a few tabs, marked as
sheet1, sheet 2, sheet 3 etc. In fact, each worksheet file contains a number of sheets. Most of the
worksheets are generally confined to a single sheet and multiple sheets are used only in complex
worksheets. On the right and bottom sides of the worksheet area, there are scroll bars.

The last line of the Excel screen is called the status line or bar. Excel uses this line to display
the following information.

- When you select a command, the left side of the status bar briefly describe the com-
mand.

- The left side of the status bar also indicates the status of operation in progress, such as
opening or saving a file, copying cells etc.

- The right side of the status bar shows the status of keys, such as caps lock, scroll lock,
Ins and Num lock.

1.7 SUMMARY :

An electronic worksheet can replace the paper sheets or ledger in most cases. These in-
clude automatic and instant recalculation of all formulas, several built in functions for performing
calculations, formatting worksheet information to give a professional look, presentation of data or
results in the form of graphs, facility to perform ‘What if-analysis’, etc. Excel developed by Microsoft
corporation is a popular worksheet program for windows.

To Start Excel, double click its icon. The Excel screen includes the menu bar, tool bars and
formula bar at the top. The rest of the area is used for entering information in the worksheet.

1.8 SELF ASSESSEMENT QUESTIONS :
1. What is an electronic worksheet ? State its applications.

2. What are the features of an Electronic Worksheet ?

3. Explain Excel Screen.

1.9 REFERENCE BOOKS :

1. Working Microsoft Office - RON MANSFIELD

2. PC Software for Windows - R.K.TAXALI

P.USHARANI



LESSON - 2

ORGANISATION OF THE WORKSHEET

2.0 OBJECTIVE : In this chapter we shall discuss :

Components of a work sheet

Entering Data in a work sheet

Saving a Work sheet.

STRUCTURE :

2.1 INTRODUCTION

2.2 ROWS AND COLUMNS

2.3 CELL AND CELLS ADDRESS

2.4 ACTIVE CELL

2.5 SELECTING CELLS

2.6 ENTERING THE TEXT IN A WORKSHEET

2.7 ENTERING NUMBERS

2.8 ENTERING FORMULAS

2.9 ARITHMETIC OPERATORS INFORMULAS

2.10 COMPARISON OPERATORS

2.11 TEXT OPERATOR

2.12 REFERENCE OPERATORS

2.13 SAVING A WORKSHEET

2.14 SUMMARY

2.15 SELF ASSESSMENT QUESTIONS

2.16 REFERENCE BOOKS

2.1 INTRODUCTION :

The worksheet area (Window) of the Excel window is the most important part because all
data that you type results of calculations and graphs are displayed area. The worksheet area is
infact a window. Generally, this window is maximised, therefore, you do not see a separate title bar
for this window. Its title bar gets merged with the Excel window’s title bar. In figure 2, the title bar
contains ‘Microsoft Excel’, the title for the Excel window and - Book I, the title for the worksheet
window. That there are two restore buttons on the right side of window. The top restore button is for
the Excel window and the lower restore button is for the worksheet window.

2.2 ROWS AND COLUMNS :

A worksheet is made up of rows and columns. There are 9 columns and 18 rows. Although
the worksheet is displaying a few columns and rows, the actual worksheet size is significantly
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larger than this. The worksheet contains 256 columns and 16,384 rows. It is worth while to com-
pare the electronic worksheet with its paper counterpart. The Excel worksheet is more than 7
metres wide and 100 metres long. It can store information equivalent to approximately more than A-
4 size sheets in a single worksheet.

See the above figure.

Row numbering in Excel is straightforward. The first row is called row 1, the second row is
called row 2 and so on. The first 26 columns are called referred to by letters A through Z. The 27th
column is called row A A, the 28th column A B, and so on.

2.3 CELL AND CELLS ADDRESS :

The area formed by intersection of row and column is called a cell. As shown in Figure 2.3,
the intersection of column D and row 12 forms a cell. The cell is the smallest unit in the worksheet
that is used to store the data. A cell is referred to by its column-row number. In Figure 2.3 the cell in
the top left corner of the worksheet that is also the active (current) cell is referred by A1. The cell
formed by intersection of column D and row 12 is referred to by D12. D12 is also called the address
of that cell. Each cell in the worksheet has a unique address. The cell address is very important in
the worksheet as it is used in the formulas to refer to a particular cell.

2.4 ACTIVE CELL :

In the work sheet, there is a thick border around one of the cells. In figure 2.3 cell A1 has a
border around it. This cell is called the active or current cell. Any data that you type is stored in the
active cell. You can make any cell in the worksheet active by using the mouse or keyboard. When
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you click the mouse on any cell in the work sheet, Excel makes that cell active and shows a border
around it. This border is also called the cell pointer.

2.5 SELECTING CELLS :

Before entering or editing cell contents, or before you can format or move cells, that they
need to be selected, you can select single cells or range of cells.

Selecting Cells with a Mouse :

To select a single cell, simply point and click in it. It becomes the active cell. The following
techniques are for rows, columns and ranges.

• Click on a row number to select the whole row.

• To select entire column of cells, point to the column’s heading

• Click and drag to select a range of cells

• Click on the empty button at the top-left corner of the workbook to select the entire worksheet

• Selecting cells with the key board.

There are many keyboard selection tricks are :

• If you have already selected a range of cells, SHIFT + SPACE BAR selects the entire row
or rows in which the cells are located.

• CTRL + SPACE BAR selects an entire column.

• CTRL + SHIFT + SPACE BAR selects the entire worksheet.

You can also move the active cell by using the keyboard. The commonly used active cell
movement keys are :

ACTIVE CELL MOVEMENT KEY MOVES ACTIVE CELL

 left by one cell, i.e. to the previous column

 right by one cell i.e. to the next column

 down by one cell i.e. to the next row

 up by one cell i.e. to the previous row

Tab right by one cell, i.e. to the next column

Shift + Tab left by one cell, i.e. to the previous column

Pg Down down by one screen

Pg Up up by one screen

Home to first column in the current row

^ Home (CTRL + Home) to cell A1

End followed by an arrow key to the end of the work sheet in the direction of the arrow
key.

F5 (GoTo) to the specified cell address.
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2.6 Entering the Text in a Work Sheet :

To enter the text used to label things in your worksheet, simply activate the cell where you
want the text to appear (point to it and click) and then begin typing. Let us enter a simple profit and
loss statement.

See the above figure

At present, cell A1 is the active cell and the entire worksheet is blank. If cell A1 is not active
cell press ^ Home.

As soon as you start typing, two changes take place. Excel changes ‘Ready’ in the status bar
to ‘Enter’ and it displays the characters being typed in the right side of the formula bar. Excel also
displays three buttons in the middle part of formula bar. The left button is called cancel button and
the middle button is called the confirm button.

• Type Profit and Loss statement

• Excel puts ‘Profit and Loss Statement in cell A1.

• Press Enter key, Excel makes the cell in the next row i.e. cell A2 active.

Look at the sample Profit and Loss Statement, we need to leave cell A2 and A3 blank and
enter ‘Cost’ in cell A4.

• Use down arrow key or the Enter key to make cell A4 active. Alternatively, you can click in
cell A4 to make it active.

• The formula bar displays A4 indicating that A4 is the active cell.

• Type cost and press Enter Key.

Excel puts Cost in cell A4 and makes cell A5 active.

• Type Overheads in cell A5 and Press Enter.

• Next, enter Sales in cell A6 and Press Enter.

• Press Enter or  to move cell to A8 and then type Profit and Press Enter or click the
confirm button.

Next we have to enter month name in row 3 starting from cell B3. We have to enter January in cell
B3, February in cell C3, March in cell D3 and April in cell E3.

• Use arrow keys or click cell B3 to make it active.
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• The formula bar displays B3 indicating that cell B3 is active.

• Now type January. Do not Press Enter or click the confirm button. Instead, Press

Excel stores ‘January’ in cell B3 and makes cell C3 active.

• Now cell C3 is active. Type February and Press

• Excel stores February in cell C3 and makes cell D3 active.

• In the same way, enter March in cell D3 and April in cell E3.

Next, let us enter number entries in the worksheet.

2.7 ENTERING NUMBERS

• Use the arrow keys or mouse to make cell B4 active. Then type 60,000 and Press Enter.

• B5 is active cell. Type 10,000 and Press Enter.

Excel accepts 10,000 in cell B5 and makes cell B6 active.

• Enter 80,000 in cell B6.

2.8 ENTERING A FORMULA :

Formulas are some times even used to manipulate text in worksheets. Usually, you place the
formula in the cell where you want to see the results. Type formulas in the Formula bar. Excel
formulas always start with = (the equal sign). Let us enter the formula for calculation of profit in cell
B8.

Use the arrow keys or the mouse to make cell B8 active.

Type = B6 - ( B4 + B5 ) and Press Enter or click the confirm button in the formula bar.

Excel immediately displays the result 10,000 in cell B8 as shown in Figure.

Notice that Excel does not display the formula in cell B8. It displays only its result in cell B8. If
you want to see the formula used in cell B8, make this cell active and Excel displays the formula
used in this cell in the formula bar, as shown in figure
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See the above figure

2.9 ARITHEMATIC OPERATORS IN FORMULAS :

Arithematic operators used in Excel are

+ Addition

- Subtraction

* Multiplication

/ Division

% Percentage

^ Exponentiation.

Simply include these at the appropriate places in formulas to perform the desired calculation.

2.10 COMPARISON OPERATORS :

Comparison Operators are usually couple with Excel’s logical functions.

The operators are :

= equal to

> Greater than

>= Greater than or equal to

< Less than

<= Less than or equal to

<> Not equal to

2.11 TEXT OPERATOR :

Excels only text operator is the ampersand (&) . It is used to combine text. For instance if you
had the word “aero” in cell C7 and the word “plane” in C8 the formula = C7 & C8 would create the
text string “aeroplane”.

2.12 REFERENCE OPERATORS :

Excel offers reference operators. The most common reference is to a range of cells. For
instance the expression B1:C3 refers to cells B1, C3 and all the cells between them

2.13 SAVING A WORK SHEET :

The worksheet that you have typed so far has been stored in the RAM of your PC. The RAM
is volatile so you must save your worksheet as a disk file in the hard disk or the floppy disk. Once a
worksheet has been saved as a disk file, it can retrieved whenever you like. In Excel, you can save
a file in three different ways.
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1. By using Save button on the standard tool bar

2. By using the Save command from the File menu

3. By using ^S (CTRL + S), the short cut keys for the Save command.

2.14 SUMMARY :

The worksheet is divided in to row and columns. The worksheet contains 256 columns and
16,384 rows. The area formed by the intersection of a row and column is called the cell. Excel
indicates the current cell by showing a border around it. This cell is called the active cell and
displays the address of the active cell in the formula bar. The data that you enter is stored in the
active cell. You can enter a constant data. or a formula in a cell. The formula refers to the data
entered in the worksheet by its cell address. A formula always begins with =’. After entering formu-
las in the worksheet, if you change data in the cells referred to by the formulas. Excel automatically
recalculates those formulas to display the correct results. This helps in performing the what-if
analysis on the worksheet data. The data entered in the worksheet can be saved in a disk file by
using the save button on standard tool bar. Alternatively you can use the Save command from File
menu or Press ^S, the short keys for the save command.

2.15 SELF ASSESSMENT QUESTIONS :

1. Describe the organisation of an Excel Worksheet.

2.16 Reference Books :

1. Working in Microsoft Office : Ron Mansfield

2. PC Software for Windows : R.K. Taxali

P.USHARANI



LESSON - 3

EDITING CELLS AND USING COMMANDS

3.0 OBJECTIVE : In this chapter we shall discuss :

 Aligning Data in cells

 Editing Data in cells

 Changing Column Width

 Changing Column Width for a Range of Columns

 Resaving a Worksheet File

 Closing a Worksheet File

 Exiting Excel

STRUCTURE :

3.1. Aligning Data in Cells

3.2. Editing Data in a Cell

3.3. Replacing Data in a Cell

3.4. Changing Column width for a column

3.5. Changing Column width for a Range of Columns

3.6. Resaving a Worksheet File

3.7. Closing worksheet File

3.8. Creating a new worksheet

3.9. Exiting Excel

3.10. Summary

3.11. Self Assessment Questions

3.12. Reference Books

3.1. ALIGNING DATA IN CELLS :

When you enter data in a worksheet, by default Excel left aligns the text entries and right
aligns the numeric entries. To change the alignment of data in cells, you can use the alignment
buttons in the Formatting tool bar or Format, cells command.
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Using the Formatting Toolbar to Align Data :

See the figure

The Formatting tool bar contains a set of four alignment buttons. The first three buttons are
used to left align, centre and right align data, respectively. You can use these buttons to change the
alignment of data in the active cell or the selected cells. The last button is useful when you want to
centre some text across a set of columns, e.g to centre the report heading on the page. Let us use
the Align Right button, to Right align data in the cell and Align Left button to left align data in the cell
and centre button to centre the data in the cell.

3.2 EDITING DATA IN A CELL :

To edit data in any cell, first you have to make that cell active. In Excel the data is always
edited in the active cell.

 Make cell D3 active and press the Function key F2 or double click in the cell.

Excel activates editing in cell D3 by displaying the cursor at the end of the entered text in the
cell. It also displays ‘Edit’ in the left side of the status bar indicating that we are editing a cell. Notice
that cell contains March that is also displayed in the Formulabar.

Excel allows you to change the cell contents either in the active cell or in the formula bar. To
edit the cell contents in the formula bar, click the mouse in the right side of the formula bar.

While editing the cell contents, you can use the usual cursor movement keys or mouse to
move the cursor. While editing the cell contents, you can use the Tab key to move the cursor
forward by five characters and shift + Tab to move it backward by five characters.

3.3 REPLACING DATA IN A CELL :

If you want to make major changes in the data entered in a cell or want to replace the data in
a cell by an entirely new data, editing cell contents may not be useful. In such a case make the cell
active whose data you want to change, type the new data and press Enter or click the confirm
button. The moment you type the first character, Excel removes the previous data from the cell as
well as from the formula bar. On pressing the Enter key or clicking the confirm button on the For-
mula bar, Excel replaces the previous data with the new data. After you have started typing the new
data for a cell, if you like to get back the previous data, press Esc key or click the cancel button on
the formula bar.
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3.4 CHANGING COLUMN WIDTH FOR A COLUMN :

While changing the column width, you have to ensure that the cell printer is positioned any
where in that column. That is, some cell in the column should be active. In Excel, you can change
the column width in many ways. First, let us learn to change the column width using the menu
system.

 If the cell pointer is not positioned in column A, use arrow keys or the mouse to make
any cell in column A active.

 Open the Format menu. To open this menu you can perform any of the following
steps :

 Click mouse on Format in the menu bar

 Press Alt +O. Notice that ‘O’ is the underlined in ‘Format’.

 Press Alt to activate the menu system. Then use arrow keys to move the
highlight cursor on Format and press Enter.

 Use any of the above methods to open the Format menu. You should get a menu as
shown in Figure.

 The Format menu contains commands to format the worksheet by formatting cells,
rows, columns etc. The command to change the column width is available in column.
Let us select this command.

 Click mouse on column. Alternatively, Press C, the hot key for the column command or
use the arrow keys to move the highlight cursor on column and press Enter.

 Excel displays another menu that contains these commands - Width, Autofit selection,
Hide, unhide and standard width. To change the width for the current column, the width
command is used.

 Choose the width command and Excel displays the width dialog box as shown in Fig-
ure.
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The column width dialog box displays the current width of the column. The width of every
column in a new worksheet is 8.43. Change the column width and press Enter or click the Ok
button.

Using Mouse to Change Column Width :

You can easily change the column width of one or more columns with the help of the mouse.

 Move the mouse pointer to the right border of column border and the shape of the

mouse pointer changes to a thick vertical line with a double headed arrow like. Then
drag the mouse pointer left or right to change the column width changing width for all
columns.

 As you know that the default width of every column in a worksheet is 8.43. You can
change the width for all columns. For doing this, you need to perform the following
steps :

 Open the Format menu

 Choose column from the Format menu.

 Choose standard width from the menu displayed by Excel

 Type the desired width in the standard width dialog box.

Excel applies the new width to all columns.

3.5 CHANGING COLUMN WIDTH FOR A RANGE OF COLUMNS :

Some times you may like to change the width for a range of columns. Instead of changing the
column width separately for each column, you can select all columns whose width you want to
change and then use the Format column, width command or use the mouse to change the column
width. For ex. select the column range from column B through E profit & loss statement worksheet
that is currently open.

 Move the mouse pointer on the column letter B in the column border at the top of the
worksheet area. Then click the mouse button. Excel selects column B and highlights
all cells of this column.

 Now the mouse pointer on the column letter ‘E’ in the column border, press the shift key
and click the mouse button.
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Excel selects the column range B through E as shown below :

See the above figure

You can also drag the mouse on the column border to select multiple columns.

Now you can use the Format, column, width command to change the column width for the
selected column range. If you prefer to use the mouse, you can drag the right border of any column
( in the column border ) of the selected column range. Excel applies the new width to all columns of
the selected column range.

Changing Column Width for a Column Range Using Key Board :

You can also change the column width for a range of columns using the key board. Let us try
to change the width for column B through E using the key board. Perform the following steps.

 Move the cell pointer to any cell in column B.

 Press the shift key and press the  key once.

 Keep the shift key pressed and then press  twice to extend the range up to
column E.

 Choose the Format column width command from the menu.

 Excel displays the column width dialog box.
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 Type the desired column width in the box and press Enter and Excel applies the
new width to the column range.

3.6 RESAVING A WORKSHEET FILE :

 Choose the File, Save command from the menu

 Press ^S the short cut keys for the File, Save command.

 Click the save button on the standard tool bar.

 Use any of these methods to save the worksheet.

3.7 CLOSING A WORKSHEET FILE :

 Choose the File, Close command from menu.

 Press ^F4 (CTRL + F4 ) keys.

 Double click the control menu box for the worksheet window.

 When you use any of these steps, Excel closes the worksheet file.

3.8 CREATING A NEW WORKSHEET :

When you start Excel, it automatically creates a new worksheet. To create a new work sheet
perform any of the following steps :

 Open the File menu. Then choose the New command from the File menu.

 Press ^ N, the short keys for the File, New command.

 Click the New button on the standard tool bar.

 On using any of these steps, Excel creates a new worksheet.

3.9 EXITING EXCEL :

 Open the File menu and choose the Exit command from the File menu.

 Press Alt + F4 keys

 Double click the control menu box located on extreme left of the Excel title bar.

 If you have already save all worksheet files, windows closes Excel.

3.10 SUMMARY :

By default, Excel left aligns text entries. By using the Formatting tool bar or the Format cells
command, the cell data can be aligned, right aligned and centered. To display the complete data in
a cell, you can increase the width for a single column, a range of columns or even all columns in the
worksheet. After making changes an existing worksheet file, When you use the File, Save (^S)
command. Excel resaves the worksheet File. When you are finished with a close it using the File,
close command.
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3.11 SELF ASSESSMENT QUESTIONS :

1. What are the steps to be taken to Align the Data in a worksheet ?

2. How do you Replace the Data in a cell ?

3. How do you change column width for a column, and range of columns ?

3.12 REFERENCE BOOKS :

1. Working Microsoft Office - RON MANSFIELD

2. PC Software for Windows - R.K.TAXALI

P. USHA RANI



LESSON - 4

MOVING AND COPYING INSERTING AND

DELETING ROWS AND COLUMNS

4.0 OBJECTIVE :

In this lesson we shall discuss

 Opening an Existing worksheet File

 Moving Data Using Mouse and keyboard

 Undoing the last action

 Inserting Rows and Columns

 Erasing a part of the worksheet.

STRUCTURE :

4.1 Opening an existing worksheet file moving data

i) Cut and paste commands

ii) Using the mouse to move the data

4.2 Copying the Data to another area

i) Copying a single cell to new location

ii) Copying a range

iii) Copying a single cell to several cells

4.3 Undoing last Action

4.4 Inserting a row in the worksheet

4.5 Inserting a column in the worksheet

4.6 Erasing part of a work sheet

4.7 Deleting rows

4.8 Deleting Columns

4.9 Summary

4.10 Self Assessment Questions

4.11 Reference Books

4.1 OPENING AN EXISTING WORKSHEET FILE :

OPEN THE FILE MENU

Notice that at the bottom of the File menu, Excel displays a list of the recently opened files. If
the file you wish to open is displayed in the File menu, you can select it from the File menu.
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See the above figure

If you want to open profit.XLS worksheet file perform any one of the following steps.

- Click mouse on profit.XLS in the menu

- Press 1 (the hotkey for ‘1’ profit.XLS)

- Use arrow keys to highlight profit.XLS and then press Enter to choose it.

If the file that you want to open is not listed in the File menu then use open command. To use
this command you can perform any of the following steps :

- Open the File menu. Then choose the open command from the File menu.

- Without opening any menu press ^O, the short keys for the File, open command.

- Click the open button on the standard tool bar. On using any of these steps Excel dis-
plays the open dialog box. This dialog box enables you to select the worksheet file that
you want to open.

MOVING DATA :

Excel allows to easily move the data from one cell to another. You can also move the data
from range of cells to a new location in the worksheet. Excel allows you to move data in two
different ways - by using the cut and paste commands or by using the mouse.

USING CUT AND PASTE COMMANDS :

The cut and paste commands move the selected data in two steps. First use the cut com-
mand to cut the source data in the memory. Then move the cell pointer to the destination area (Cell)
and use the Paste command. Then Excel removes the data from the source and puts it in the
destination area. Let us move ‘profit and loss statement’ entered in cell A1 to cell B1
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See the above figure

 Press ^ Home ( or Home) or click cell A1 active.

Use cut command in any of the following ways :

1. Open the Edit menu and then Select the cut command from the menu.

2. Without opening any menu Press ^X, the short cut keys for the cut command.

3. Click the cut button in the standard tool bar.

Excel has put the data from cell A1 memory and displays the following message in the status
bar.

Select destination and Press Enter or choose Paste.

 Since we want to move the data to cell B1

Press  to move the cell pointer to cell B1. Then press Enter key.

Excel moves the ‘Profit and Loss statement’ from cell A1 to cell B1 as shown below.
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See the above figure

PASTE COMMAND :

Let us try to move profit and loss statement from cell A1 to B1 by using paste command.

Now let us paste the cut text in the current cell. To paste the cut text use any of the following steps
:

1. Open the Edit menu and then select the paste command from the menu.

2. With opening any menu press  the short cut keys for the paste command.

3. Click the paste button in the standard toolbar.

 Use any of the above steps Excel paste the cut text in cell B1 and deletes the text
from cell A1. Moved the data from cell A1 to B1.

USING THE MOUSE TO MOVE DATA :

You can easily move data form one cell or range of cells to another cell in the worksheet.

- Click the mouse in cell A1 to make it active

- Move the cell pointer to cell border

- Mouse pointer is on the cell border, press and hold the mouse button and Excel displays
the message in the status bar - ‘Drag to move cells’

- Without releasing the mouse button, drag the mouse pointer to cell B1.

Excel displays the grey border around cell A1
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- While Excel is displaying the grey border around cell B1 release the mouse button, and
Excel moves ‘profit and loss statement’ from cell A1 to B1.

In this exercise we move a single cell. If you select multiple cells (range) before moving. You
can move all of them to a new location in the worksheet by using the mouse or the cut and paste
commands or buttons.

4.2 COPYING DATA TO ANOTHER AREA :

While enter the data in a worksheet, sometimes need to enter the data already existing in one
part of the worksheet to another. Copying can be used for any of the following applications.

- To copy a single cell to a new location

- To copy a range of cells to any new area in the worksheet.

- To copy a cell or range to multiple cells.

4.2.1 Copying a single cell to new Location :

Using Copy Command :

Let us copy the contents of cell E4 to F4 Move the cell pointer to E4.

- Open the Edit menu and then select the copy command from the menu.

- Without opening any menu, press ^C the short cut keys for the copy command.

- Click the copy button in the standard tool bar.

Excel has put the data from cell E4 in the memory and displays the following message in the
status bar.

“Select destination and press Enter or choose paste”

Since we want to copy the data to cell F4

Press  to move the cell pointer to cell F4.

Then press Enter key.

PASTE COMMAND :

After moving the cell pointer to cell F4, you could have also used the paste command instead
of pressing the Enter key.

- Open the Edit menu and then select the paste command from menu.

- Without opening any menu, press ÙÚ the short cut keys fro the paste command.

- Click the paste button in the standard tool bar.

4.2.2 COPYING A RANGE :

 Let us use Excel’s copy and paste commands to copy a range. You can select the range
with the key board or mouse.

 Move the cell pointer to cell E5. This is the first cell of the range.

 Press and hold the shift key. Now without releasing the shift key, Press the  key three
times to select the range E5 : E8.
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- Excel selects the range E5 : E8 as show below.

- Press ^C or click the copy button on the standard tool bar to copy the selected range to
clip board.

See the above figure

It also displays the message ‘ select destination and press Enter or choose paste ‘ in the
status line.

Let us copy the data from clipboard to the range F5 : F8.

- Move the cell pointer to F5

- Press the Enter key and Excel paste the range from clipboard to F5 : F8 as shown below.
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See the above figure

4.2.3 COPYING A SINGLE CELL TO SEVERAL CELLS :

The copy command can be used to copy a single cell across several column and rows. The
procedure is almost similar to copying a single cell to a new location.

Using the Mouse to copy data.

Copying the data from F3 : F8 to G3 : G8.

 Press and hold the mouse button in cell F3 without releasing the mouse button, drag
the mouse to select the range F3 : F8. After you have selected the range F3 : F8
release the mouse button.

 Press and hold the CTRL key move the cell pointer cell G3 and drag the mouse pointer
to cell G8 and release the mouse button.

Excel copies the data from range F3 : F8 to G3 : G8.

4.3 UNDOING LAST ACTION :

Excel allows to undo the last command in most cases.

 To use undo command click undo button or press ^Z, the short cut keys for this com-
mand. If you want to use the menu, the undo command is available in the Edit menu.

4.4 INSERTING A ROW IN THE WORKSHEET :

Excel inserts row(s) above the currently selected row(s). Therefore to insert a row above row
1, you have to select the row 1 or some cell from row 1 before using the Insert Row command.

 Move the cell pointer to any cell in row1. Then open the Insert Menu.

Excel displays the Insert menu.

See the figure



Centre for Distance Education Acharya Nagarjuna University4.8

 Choose the Rows command from Insert menu and Excel inserts a blank row at the top
of the worksheet.

See the above figure

4.5 INSERTING COLUMNS :

The procedure to insert columns in almost identical to inserting rows, except that you have to
use the columns command instead of Rows in the Insert menu. Let us insert a column to the left of
column B.

 Select any cell from column B.

 Open the Insert menu and then choose the columns command from the menu.

Excel inserts a column to the left of column B and renumbers all columns.

4.6 ERASING PART OF A WORKSHEET :

Sometimes you may want to erase a part of the worksheet. If you want to erase a single cell,
all you need to do is to make that cell active and press Del key. If you want to select multiple cells,
select those cells with the mouse or keyboard and press Del key.

4.7 DELETING ROWS :

You can delete one or more rows with the mouse or by using the key board.
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Using the mouse :

Let us use the mouse to delete row 2

 Move the mouse pointer on 2 in the row border on the left side of the worksheet. Click
the mouse and Excel selects row 2.

 Right click the mouse anywhere in the selected row.

Excel displays short cut menu.

 Click the Delete command in the short cut menu. Excel deletes (erases) data from all
cells of row 2 and then it shifts the data form the following rows up by one row. Excel
automatically renumbers all rows and updates all formulas used in the worksheet.

If you want to delete multiple rows, you can select them by dragging the mouse pointer in the
rows in one stroke.

4.8 DELETING COLUMNS :

Let us use the mouse to delete column C using the mouse :

 Click the mouse on ‘C’ to select column C.

 Right click the mouse anywhere in the selected column.

 Choose Delete command from short cut menu and Excel deletes column C.

Using key board - Deleting Rows :

Let us try to delete the row 3.

 Activate any cell in row 3.

 Open the Edit menu

 Excel displays the Delete Dialog box.

 Since we want to delete a row, Press R to select the Entire Row.

 Now press Enter Excel deletes the row.

Deleting Columns :

Let us try to delete column B with the key board.

 Move the cell pointer on any cell in column B

 Open Edit menu. Then select the Delete command from the Edit menu.

 Excel displays the delete dialog box.

 Press C to select the entire column

 Now press Enter and Excel deletes column B.

4.9 SUMMARY :

To open an existing worsheet file, we can use the File, open (^O) command or the open
button on the standard tool bar. This command displays the open dialog box and then we can select
any worksheet file from any directory for opening. Any of the recently used files can be opened by
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selecting its file name from the File menu.

Excel allows you to move the data from any part of the worksheet to another. You can move
a single cell or multiple cells. To move data to a new location, you can use the cut and paste
commands or buttons. You can use the copy and paste commands or buttons to copy data from
one part of the worksheet to another. The copy and move operations can also be accomplished
with the help of a mouse. A single cell can also be copied to several cells.

While working on a worksheet, if you make any mistake, you can use the undo command.

You can insert rows and columns to insert more data. The commands to insert rows and
columns are available in the Insert menu. Similarly you can delete rows and columns from your
worksheet. If you do not want to save the modified worksheet., close it and select ‘No’ when Excel
prompts you to save changes.

4.10 SELF ASSESSMENT QUESTIONS :

1. How do you move the data in a worksheet ?

2. How do you copy the data in a worksheet ?

3. How do you insert rows and columns in a worksheet ?

4. How do you delete rows and columns in a worksheet ?

5. Explain cut and paste commands.

4.11 REFERENCE BOOKS :

1. Working Microsoft Office - RON MANSFIELD

2. PC Software for Windows - R.K.TAXALI

P. USHA RANI.



LESSON - 5

EXCEL FORMATING TIPS AND TECHNIQUES

5.0 OBJECTIVE :

After going through this lesson the student can know how can a worksheet be made most
attractive or useful.

STRUCTURE :

5.1 Introduction

5.2 Adjusting column width and Row Height

5.3 Inserting and Deleting Rows and columns

5.4 Inserting and Deleting Cells

5.5 Moving and copying cell contents

5.6 Using Drag-and-Drop

5.7 Using Styles

5.8 Creating Styles

5.9 Modifying styles

5.10 To Alter Number’s Appearance

5.11 Changing Font Sizes and Attributes

5.12 Using Border Buttons and Commands

5.13 Changing Colors and Shading

5.14 Inserting and Removing page Breaks

5.15 Hiding rows and columns

5.16 Summary

5.17 Model Questions

5.18 Reference Books

5.1 INTRODUCTION :

Excel provides many formatting features that can enhance the appearance of your worksheets.
You will be amazed at how quickly column widths and row heights can be adjusted with a simple
mouse click or drag. Excel Auto Format feature can make it most attractive and useful presenta-
tion.

5.2 ADJUSTING COLUMN WIDTH AND ROW HEIGHT :

By default, Excel columns are slightly more than eight characters wide. If the data in a worksheet
is wider or much narrower than the column, you will want to adjust the column width so it is wide
enough to contain the data, but not so wide that data seems lost. You can adjust column width
manually or use Auto Fit to fit the column width to the existing data.
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To adjust the width of a column manually, begin by pointing to the border at the right side of the
column header. The mouse pointer will change to an adjustment tool, shaped like a double-headed
arrow. Drag the edge of the column header to the desired width, and then release the button. If you
double click on the column header border instead of dragging the border, Excel will Autofit the
column, making the column slightly larger than the widest entry in the column.

You can select several columns and size them all at the same time. By dragging the header
border of any selected column, all columns will be sized to the same width. Double clicking the
header border of any of the selected columns will size each column individually, to fit the data in the
column. You can also select the columns you want to adjust and select Autofit from the menu
(choose Format > Column > AutoFit selection ).

Never leave blank columns between columns in a worksheet. Blank columns create prob-
lems with charts, sorting and many other advanced features. Instead, adjust column widths to
provide adequate space for and between entries.

You can adjust row height the same way you adjust column width, If you move the pointer to
the lower edge of a row heading, the pointer will change to an adjustment tool. Double-click to
adjust the row height to fit the font size; drag to manually increase or decrease size. To adjust
column width and Row height follow these steps :

1. Select the columns you want to adjust

2. Position the mouse pointer at the right edge of one of the selected column’s headings.
The pointer will change shape to a double headed arrow.

3. Double click to have Excel adjust the widths of the selected columns to fit the contents
of the columns

4. Click any where in the worksheet to turn off the selection.

5. To adjust column widths manually, drag the right border of a column’s heading to make
the column wider or narrower.

5.3 INSERTING AND DELETING ROWS AND COLUMNS :

To insert a column between the current columns Aand B, begin by selecting column B, Right-
Click and select Insert from the shortcut menu or choose Insert > columns from the menu bar to
insert a column. To insert multiple columns simultaneously, select more than one column before
inserting. For example, you can insert three columns by first selecting B, C and D. You can insert
rows in the same fashion.

To Quickly insert a single row or column, select the row or column heading by right-clicking.
As soon as the row or column is selected. Excel immediately opens the shortcut menu.

Deleting rows and columns is much like inserting. Begin by selecting one or more rows or
columns. To clear the contents but leave the emptied row in place, press the Delete key on your key
board. To delete the contents and remove the row or column, Choose Edit > Delete from the menu
bar when you delete a row or column, all information is deleted, including cells that may not be in
the part of the worksheet you can see.

The steps for Inserting and deleting Rows and columns are :

1. Select the row or column where you want the new inserted column to appear.
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2. Right-click and choose insert or choose Insert > Rows from the menu bar to insert a
row. To insert a column from the menu bar, choose Insert > columns.

3. To delete a column or row, first select it. Then right-click and choose Delete, or choose
Edit > Delete from the menu bar.

5.4 INSERTING AND DELETING CELLS :

Sometimes, you will need to add or delete cells in part of a worksheet without inserting or
deleting entire rows or columns. For this, select the range where new cells should be inserted, and
then right click and choose Insert. When you insert or delete rows and columns, Excel automati-
cally moves the surrounding rows and columns to fill the gap. If you insert or delete cells, Excel
needs more instruction to know how to move the surrounding cells, so the Insert or Delete dialog
box opens.

If you choose shift cells Down, the cells in the selection and all cells below them in the same
columns are shifted. If you choose shift cells Right, cells in the same rows are moved to the right.
Notice that you can also use this dialog box to insert rows or columns.

5.5 MOVING AND COPYING CELL CONTENTS :

If you want to move or copy data from one worksheet to another, cut or copy the selection,
and then click the sheet tab for the sheet that you want to paste into. Click in the appropriate cell and
then press Enter to paste. If you want to move or copy data from one workbook to another, both
workbooks must be open. Select and cut or copy the data and then choose window from the menu
bar and select the destination workbook from the list of open workbooks. Click in the destination cell
and press Enter key.

In brief the steps are :

1. If there is data below or to the right of the paste area, begin by inserting enough blank
cells, rows or columns for the data you want to move or copy.

2. Select the data you want to move or copy. To move, click the cut button, choose Edit >
cut or right click and select cut form the shortcut menu. To copy, click the copy button,
choose Edit > copy or right click and select copy from the shortcut menu.

3. Select the first cell, row or column where you want to place the moved or copied data.

4. Press Enter to move or copy the data to its new location.

A New feature in office 2000 is the office clipboard. It allows you to save up to 12 items on the
clipboard and then paste them one at a time or all of them at once. To turn on the clipboard toolbar,
choose View > Toolbars > clipboard.

5.6 USING DRAG AND DROP :

When you are moving or copying cells between worksheets or workbooks, it is easiest to cut
or copy and paste. Another method, called drag and drop, works well when you can see the cells to
be copied and their destination on one screen. Follow these steps :

1. Select the cells rows or columns to be moved or copied.

2. Point to any part of the cell pointer. The mouse pointer will change to an arrow shape.
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3. To move the selection, drag it and drop it in its new location. To copy a selection hold the
ctrl key while dropping the selection.

5.7 USING STYLES :

Styles are collections of formatting decisions that include number format, alignment instruc-
tions, border specifications, pattern selections, and cell protection decisions.

APPLYING STYLES :

To Apply styles, follow these steps :

1. Select the cell or cells you want to format.

2. Choose style from the Format menu.

3. Pick the desired style from the drop-down style Name list in the resulting style dialog
box.

4. Click once on the Name and once on ok to apply the style.

5.8 CREATING STYLES :

The easiest way to create a new style is to format a cell to meet your requirements (number
format, font, borders and the like) and then name it. Here are the steps :

1. Format the cell to your liking

2. With that cell still the active cell, choose style from Excel’s Format menu.

3. Type a new style name in the style Name portion of the style dialog box. Click the modify
button to set changes.

4. Click ok to save the style, which will be added to the drop-down list and saved with your
document.

5.9 MODIFYING STYLES :

Modifying an existing style requires a visit to the style dialog box and some typing :

1. Modify a cell containing the style of interest.

2. Choose Format / Style to open the style dialog box.

3. Click the drop-down list button to display the drop down list and choose the old style
name from it. Alternatively, type the old style name in.

4. Excel may ask if you want to redefine the style based on the changes you have just
made. Answer yes to redefine the style choose No to leave style unchanged.

5.10 TO ALTER NUMBER’S APPEARANCE :

Excel comes with a variety of format codes organised by type. You can get the list of code
categories in the Format cells dialog box. Here are the steps to apply a code :

1. Select the cell or cells to be reformatted.

2. Choose Format 1 Cells or use the Ctrl + 1 shortcut.

3. Bring the Number tab forward if it is not already on top by clicking on the Number tab.
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4. Click on a category to display the available format.

5. Double click on a format code to use it or click once on the name of the code and once
on ok.

6. Reformat columns if necessary to accomodate changes in the number’s width.

5.11 CHANGING FONT SIZES AND ATTRIBUTES :

Use the Formatting tool bar’s drop-down font name and size lists to change those font fea-
tures. Use the Bold, Italic, and underline buttons to add those attributes to your worksheet.

A number of alignment buttons are available on the standard and Formatting toolbars. Use
these to shift the horizontal position of cell contents flush left, flush right or to the center of cells. In
addition, the Alignment tab in the Format cells dialog box offers many choices. From here you can
also specify how text and numbers will be positioned vertically within selected cells. For instance,
you can center short type in tall rows. Text can be flipped with the orientation buttons, so that it runs
top to bottom or bottom to top within cells.

5.12 USING BORDER BUTTONS AND COMMANDS :

Borders can be used to set apart related worksheet sections and to emphasize totals and
subtotals. or use them just for decoration to enhance the worksheet’s appearance.

Borders can be created by using buttons on the Formatting toolbar :

1. Select the cell or Cells you want to embalish.

2. To outline selected cells with a border, click the Border button arrow on the Formatting
toolbar. The key board short cut is ctrl + Shift + &.

3. Pick the desired border setting by pointing to the desired border style.

You can also construct custom borders in the he Border tab of the Format cells dialog box.

1. Select the cells you want to enhance.

2. Open the style dialog box and click modify.

3. Click the Border tab.

4. Click to pick a border element (left, right and so on)

5. Pick line types (thick, thin, single, double or whatever)

6. Repeat steps 4 and 5 until you are satisfied.

7. Click Ok.

To Remove all the borders from a selected range or cell, you can use the ctrl + shift + Under-
line (-) keyboard shortcut, or choose the No Borders choice in the Borders palette.

5.13 CHANGING COLORS AND SHADING :

You can change the color of selected text, cell shading, and other items with the color button
and Text color button found on the Formatting toolbar.

In addition you can use the patterns tab in the Format cells dialog box.
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5.14 INSERTING AND REMOVING PAGE BREAKS :

Excel makes page break decisions automatically, but sometimes you will want to force new
pages elsewhere. Do this by activating the cell beneath and to the right of where you want a page
break and then choose set page Break from the Insert menu. Dark dashed lines will mark the new
page breaks.

To remove breaks, activate the cell below and to the right of the break lines and choose
Remove page Break, the command replaces page break on the Insert menu.

5.15 HIDING ROWS AND COLUMNS :

You can hide rows or columns without destroying their contents, then reveal them later when
you want to see or edit them.

1. Select the row (s) or columns(s) you want to hide.

2. Choose the appropriate Hide and unhide commands on the Format menu’s Row and
Columns choices.

5.16 SUMMARY :

To enhance the appearance of our worksheet you can use the Excels formating features.
With the help of these features we can adjust column width and Row height. Insert or Delete Rows
and columns as well as cells. You can move or copy cell contents by using styles we can format
numbers, can give alignment instrucitons, border specifications. You can select the pattern and
cell protection decisions also will be taken.

5.17 MODEL QUESTIONS :

1. Breifly Describe the formating features of Excel.

2. How can you Insert and Delet Rows, columns and cells by using formating features of
Excel.

3. What is style ? How can you use styles in Formating.

4. Explain the method of changing colors and shades of Text in worksheet.

5. How can yoiu Insert and Remove Page Breaks ?

5.18 REFERENCE BOOKS :

1. Working Microsoft Office - RON MANSFIELD

2. PC Software for Windows - R.K.TAXALI

P.USHARANI



LESSON-6

ORGANISING LARGE PROJECTS

6.0 OBJECTIVE :

After going through this lesson the student can know how to name things ? And how to split
windows to make it easier to view widely separated parts of a document.

STRUCTURE :

6.1 Introduction

6.2 Creating Names

6.3 Splitting Windows

6.4 Outlining Worksheets

6.5 Linking Worksheets

6.6 Viewing Multiple Windows

6.7 Summarizing Information from Multiple Worksheets

6.8 Printing Tips for Large Excel Projects

6.9 Summary

6.10 Model Questions

6.11 Reference Books

6.1 INTRODUCTION :

Projects take many shapes and sizes. Sometimes you will need to deal with a few big
worksheets. Other times you will need to work with lots of little ones. Excel offers a number of
features to help you view, edit, navigate and consolidate big projects.

6.2 CREATING NAMES :

Excel can create names for selected cells based on row and column headings. The steps
are as follows :

1. Select cells you want to name (including headings)

2. Choose Name from the Insert Menu

3. Choose create from the resulting submenu, you will see the create Names dialog box.

4. Choose the label locations you want to use as names. Excel will use those labels to
assign names automatically, modifying them as necessary to fit the naming rules.

5. Repeat the steps as often as necessary to name different areas. The F4 shortcut works
great for this.

Suppose you wanted to define something manually. You could use the following general steps :

1. Select cells you want to name.

2. Choose Name from the Insert menu

3. Choose Define from the resulting submenu.
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4. You will see the Define Name dialog box.

5. Excel proposes a name if
it can.

6. Click Ok to accept the pro-
posed name, or type a
name and then clickAdd or
Ok.

7. Repeat the steps as often
as necessary to name dif-
ferent areas. The F4 (Re-
peat) shortcut works great
for this.

Once you have created named
items they can be used in many
ways. For instance create formulas.

See the figure

Type a formula in the cell
where you want the resulting value
to appear. Every formula must begin
with an equal sign (=) for ex : = A1 +
A2 (Enters the total of the values in
cells A1 and A2).

6.3 SPLITTING WINDOWS :

Excel document windows can be split into two or four separately scrollable panes that make
it easy to see different parts of your worksheet at the same time.

Use the split command on the window menu to create four panes in the neighborhood of the
active cell. Each pane will have its own scroll tools, which can be used to position each pane’s
contents independently.

6.4 OUTLINING WORKSHEETS :

Excel’s outline feature lets you expand and collapse large worksheets. For instance you
could create an annual budget containing annual totals and monthly and quarterly subtotals. Then
collapse it to view and print quarterly subtotals and annual totals. You could collapse it further to
show only annual totals.

Automatic Outlines :

Excel will automatically out line for you, To outline automatically :

1. Start by selecting any single cell in the worksheet.

2. Use the Data / group and outline / Auto outline command.

3. Excel will look for subtotals, titles and other recognizable elements; create an outline;
and display the worksheet with additional outline tools.
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Once you have outlined a document you will see outlining tools along the top and left edges of
the worksheet.

Although automatic outlines are much easier to create, you can use the utility toolbar to
outline manually.

If you don’t want to see the outline symbols because they rob some of your screen space,
turn them off using the CTRL + 8 keyboard shortcut or use the clear outline command found on the
group and outline submenu of the Data menu.

6.5 LINKING WORKSHEETS :

There are many reasons to work with multiple worksheets. You might need to combine de-
partmental budgets into a company-wide total budget.

Each new project can have multiple worksheets. Excel’s ability to “round up” related files
even if they are in different workbooks save a great deal of time for you.

It is possible to link contents of one worksheet with another, regardless of whether the
worksheets are in the same workbook.

Here are the general steps :

1. Open both workbooks; and switch to the appropriate worksheets.

2. Select and copy the cell or cells containing the numbers you want to link.

3. Switch to the worksheet where you want to paste the numbers.

4. Select Edit / Paste special and choose the paste link option. The path to the linked item
will appear in the Formula bar.

Moving a worksheet within a workbook or between workbooks :

An easier way to copy or move worksheets within a workbook is to use the drag and drop
feature. First, select the tab of the worksheet (s) you want to copy or move. Move the mouse pointer
over one of the selected tabs, click and hold the mouse button and drag the tab where you want it
moved. To copy the worksheet, hold down the CTRL key while dragging. When you release the
mouse button, the worksheet is coped or moved.

You can move or copy worksheets between workbooks. First open the workbooks you want
to use for the copy or move. Choose window, Arrange and select the Tiled option. Click ok to
arrange the windows so that a small portion of each one appears on screen. Select the tab of the
worksheet(s) you want to copy or move. Move the mouse pointer over one of the selected tabs.
Click and hold the mouse button and drag the tab where you want it moved. To copy the worksheet,
hold down the CTRL key while dragging. When you release the mouse button, the worksheet is
copied or moved.

Changing worksheet Tab Names :

By default, all worksheets are named “sheet X “, where X is a number starting with the num-
ber 1. So that you will have a better ideal of the information each sheet contains, you can change
the names that appear on the tabs. Here is how you do it :

1. Double click the tab of the worksheet you want to rename. The current name is high-
lighted.

2. Type a new name for the worksheet and press Enter. Excel replaces the default name
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with the name you typed.

6.6 VIEWING MULTIPLE WINDOWS :

Sometimes it is useful to see more than one sheet or more than one workbook on screen.
Use there general steps :

1. Choose New window from the Excel window menu for each additional window you want
to display.

2. Choose Arrange from the window menu and make your desires known in the Arrange
windows dialog box. For example, the windows here are tiled. Experiment.

See the above figure

3. Drag the window borders or corners with your mouse if you want to fine-tune.

6.7 SUMMARIZING INFORMATION FROM MULTIPLE WORKSHEETS :

Often when you have a workbook containing a sheet for each department, or several work-
books containing related information, you might want to create a summary sheet containing com-
pany wide totals. This process is called summarizing or consolidating.

One way to consolidate information is to create an additional worksheet with equations that
sum the data from the others. For instance, suppose you had stores in three different places. You
have created a profit and loss Account statement for each store on a separate sheet in the same
workbook. You might decide to create a fourth sheet that consolidates the data three stores. Here
are the general steps :

1. Create a New sheet that will be used to contain the consolidated numbers.

2. Activate a cell needing an equation in the consolidated sheet.

3. Type an equal sign (=) to begin the equation.

4. Continue the equation until you need to refer to a cell.

5. When it is time to refer to a cell, click on the tab for the first sheet to be included in the
consolidation.

6. Click on the cell to be included on in the equation.
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7. Shift-click on the tab for the last sheet to be included in the consolidation.

8. Finish the equation back in the consolidation sheet.

6.8 PRINTING TIPS FOR LARGE EXCEL PROJECTS :

A workbook is a collection of many worksheets, which are like pages in a notebook. You can
print the whole notebook at once, or just one or more pages at a time.

You can tell Excel what part of the worksheet you want to print using the print area option.
This option lets you single out an area as a separate page and then print that page. If the area is too
large to fit on one page, Excel breaks it into multiple pages.

Before you print a worksheet, you should make sure that the page is set up correctly for
printing. To do this, open the file menu and choose page set up.

After you have determined your page setup and print area, you should preview what the
printed page will look like before you print. To preview a print job, open the File menu and select print
preview or click the print preview button in the standard toolbar. Your workbook appears on the
screen as it will when printed.

After previewing your data, it is time to print. You can print selected data, selected sheets or
the entire workbook. To print your workbook, follow these steps :

1. If you want to print a portion of the worksheet, select the range you want to print. If you
want to print one or
more sheets within
the workbook, select
the sheet tabs. To
print the entire work-
book, skip this step.

2. Open the File menu
and select print (or
press CTRL + P).
The print dialog box
appears.

See the figure

3. Select the options
you would like to use.

4. Click Ok or press
Enter.

6.9 SUMMARY :

Projects take many shapes and sizes. Excel offers a number of features to help you view,
edit, navigate and consolidate big projects.

6.10 MODEL QUESTIONS :

1. How can you create Names ?

2. How can you split windows.
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3. Explain the procedure of outlining worksheets

4. How can you link worksheets.

5. How can you view multiple windows in a single window ?

6. How can you consolidate worksheets ?

7. Explain printing steps in a worksheet
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LESSON - 7

EXCEL’S CHART FEATURES

7.0 OBJECTIVE :- After going through this lesson the student can understand what are

charts ?  How to prepare charts and its objects.

STRUCTURE :

7.1 Introduction

7.2 Types of Charts.

7.3 Creating a Chart

7.4 Moving, Sizing Charts

7.5 Printing Charts

7.6 Editing and Formatting Charts

7.7 Adding Data Series to a Chart

7.8 Deleting a Data Series

7.9 Modifying and Formatting Charts

7.10 Using the Chart Tool Bar

7.11 Inserting and Formatting Titles

7.12 Exploding Peis

7.13 Summary

7.14 Model Questions

7.15 Reference Books

7.1 INTRODUCTION :

Charts are graphical representations of numeric data. Charts make it easier for users to
compare and understand numbers, so charts have become a popular way to present numeric
data. Every chart tells a story. Stories can be simple “how our sales have increased.” Ths is the
overhead costs relate to total cost production”. What ever may be the story, the story should be
readily understandable. A good chart always be able to reveal the story to the viewers. If you can’t
immediately understand what a chart means, it is not a good chart.

Once you have created a chart, you can print it, hide it, spell check it, modify it, or even
include it in your non-Excel projects such as word or power point documents.

Whenever you change data in a worksheet, Excel will update charts that are linked to the
changed data.
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7.2 TYPES OF CHARTS :

Charts are constructed with data points - individual numbers in a worksheet and data series.
Groups of related data points within a column or row.

The following are the different types of charts which can be prepared in Excel

1.Pie Charts :

Pie Charts are used to show the relationship between pieces of an entity. The implication is
that the pie includes all of something: all the tickets sold in a month or all the tickets sold in the first
quarter

See the above figure 7.1

A Pie chart can only include one data series. If you select more than one data series, Excel
uses the first series and ignores all others. No error message appears, so you won’t necessarily
know that the chart does not show the data you intended to include unless you examine the chart
carefully.

When you create a pie chart, Excel totals the data points in the series and then divides the
value of each data point into the series total to determine how large each data points pie slice
should be.

Pie charts almost always show relationships at a fixed point in time. The end of the year, a
specific month, day or week. It is not impossible to create a pie chart with more than one time
frame, however, this kind of information would be better represented in a series chart.
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2. Series Charts :

In a Series chart, you can chart more than one data series. This lets you compare the data
points in the series, such as January Vs February, vijayawada Vs guntur. Series charts are open-
ended : there is no requirement that the data shown is all the data for a month or year. There are
several types of series charts. You can give the same set of data a very different look by simply
chaning the chart type.

3. LINEAND AREACHARTS :

The series chart shown in Figure 6.2 is a line chart showing the relationship between ticket
sales and each city during the first quarter. Each data series is a city. Line charts are available in 2-
D version (as shown) or a in 3-D version that is sometimes called a ribbon chart. An area chart is
a line chart with the area below the line filled. Line charts and area charts are typically used to show
one or more variables. (sales, income,price) changing over time.

See the above figure 7.2

4. Column and Bar Charts :

Figure 6.3 shows the same information presented as a bar chart. The bars give added sub-
stance to the chart. In the line chart you can notice the trend up or down in each line and the gaps
between the lines. The bar chart makes all ticket sales seen more substantial, but it also makes
the difference between destinations even clearer-like why doesn’t any one vacation in Hyderabad ?
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See the above figure 7.3

Column Charts are the same as bar charts, but with the X-axis at the bottom. There are
three-dimentional varieties of bar and column charts, which add depth to the regular chart. Cylin-
ders, cones and pyramids are variations of a column chart. Excel also offers another style of bar
and column chart - the stacked chart. A stacked 3-D column chart using the same data as Fig 6.1
and 6.2 is shown in Fig 6.4. In a stacked chart, parallel data points in each data series are stacked
on top or to the right of each other. Stacking adds another dimension to the chart, since it allows the
user to compare sales between as well as within time periods like providing a column chart and a
pie chart for each time period.

See the below figure 7.4: stacked 3-D column chart
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The 3-D charts have three axes. In a 3-D column chart, the X-axis is the bottom. The vertical
axis is the Z-axis; the Y-axis goes from front to back, providing the “third dimensional” depth in the
chart.

7.3 Creating a Chart :

The easiest way to create a chart is by using the chart wizard. Begin the charting process by
selecting the data to be used in the chart. With the exception of the chart’s title, every thing that
appears in the chart should be selected some where in the worksheet. Make sure that the ranges
you select are symmetrical; if you select four lables in rows 9-12 of column A, select data points
from the other columns in rows 9-12. If you select labels in columns A-D of row 5, the data series
you select should also be in columns A-D.

If you include blank rows or extra empty columns in your selection, you will have empty
spaces in your chart. Remember that you can hold the ctrl key to select noncontiguous ranges of
data. If you select some cells you don’t want to include, press Esc and start again.

When you have your text and numbers selected, click the chart wizard button on the stan-
dard toolbar to open the chart wizard. In the first step of the chart wizard, choose a chart type in the
chart type list box (see Fig 6.5). If the type of chart you want is not listed, check out the chart types
on the custom types tab. For more information about a chart type, select the chart type, click the
chart wizard’s office Assistant button, and choose Help with this Feature. The Assistant will offer to
provide a sample of the selected chart.

See the above figure 7.5

Chart Wizard, Step I .

After choosing a chart type in the left pane, choose a subtype in the right pane. To see a rough
sample of the type and subtype using your data, use the mouse pointer to press the press and Hold
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to view sample button in the chart wizard. When you have selected a type and a subtype, click Next
to continue.

In the second step, shown in Fig 6.6, you have an opportunity to make sure the range you
selected is correct, if it is not, click the collapse Dialog button and re-select the proper range before
continuing. Choose Rows or columns in the series in option group. The preview will change to
reflect the range and series arrangement you specify click Next.

See the above figure 7.6 : chart Wizard step 2.

In the third step, use the tabs to change options for various aspects of the chart :

Titles : Enter titles for the chart and axes

Axes : Display or hide axes

Gridlines : Display gridlines and display or hide the third dimension of a 3-D chart.

Legend : Display and place a legend

Data Labels : Display text or values as data labels

Data Table : Show the selected range from the worksheet as part of the chart.

As you change options, the chart preview will reflect your changes. When you have finished
setting options, click Next to continue.

Every chart needs a title. The title provides information that is not already included in the
graphical portion of the chart. The chart’s picture, legend, and title taken together should answer
any questions about the timing, location or contents of the chart.
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In the last step of the chart wizard, you can place the chart on the current worksheet or on a
new blank sheet in the same workbook. If the chart is placed on its own sheet, it will print as a full-
size, single-page chart whenever it is printed. If you add it to the current worksheet as an object, it
will print as part of the worksheet, but it can also be printed separately. Don’t spend a lot of time
deciding whether to place the chart in this worksheet or its own worksheet. You can easily move it
later. Enter a new sheet name, or choose as object in, and click finish to create and place the chart.

Steps in creating a chart :

1. Select the cells to be included in the chart.

2. Click the chart wizard button on the standared tool bar.

3. In the first step, select a chart type and subtype; then click next.

4. In the second step, verify that you have selected the correct range and choose to have
the series represented by rows or by columns, click Next.

5. In the third step, use the tabs to move to the various options for the chart. On the title tab,
enter a chart title. Set other options as you wish, and then click Next.

6. In the fourth step, either enter the name for a chart worksheet or leave the default setting
to place the chart as an object in the current worksheet click Finish.

7.4 Moving, Sizing Charts :

For the purpose of moving and sizing charts, click once on the chart to select it. To deselect
the chart and return to the worksheet, click once on the part of the worksheet that is not covered by
the chart.

Once the chart is selected, you can move it by pointing to the chart and holding the mouse
button down until the pointer changes to a four headed arrow. Drag the chart to its new location. To
change the chart’s size, move the mouse pointer to one of the chart’s hands. Press the mouse
button and drag the handle to stretch or shrink the chart. Handles on the sides of the chart change
the size in one direction (width or height). To increase width and height in proportion, use a corner
handle.

You might want ot turn on Page Break Preview when sizing and moving charts to make sure
they remain within the boundaries of a page. Page Break Preview is not an option while a chart is
selected, so click anywhere in the worksheet to deselect the chart, and then choose view > Page
Break Preview.

7.5 Printing Charts :

Even if you place your chart as an object in the current worksheet, you can still print it sepa-
rately. If the chart is selected when you print, it will print by itself on a full page. If the worksheet is
selected, the worksheet prints, including the chart object.

1. To print a worksheet, including a chart object, activate any worksheet cell before printing.

2. To print a chart object as a full page chart, select the chart before printing.



Centre for Distance Education Acharya Nagarjuna University7.8

7.6 Editing and Formatting Charts :

Creating a chart in Excel is really easy and often you can use one of Excel’s preformatted
charts right “out of the box”. But you can also customize charts so that they reflect exactly the
emphasis and information that you want to convey.

7.7 Adding Data Series to a Chart :

Excel’s charting tools allow you to modify charts quickly and easily. You can, for example,
create a simple series chart and then add another data series using drag-and -drop. You cannot
add individual data points, just data series.

1. In the worksheet, select the data series to be added.

2. Drag the series and drop it in the chart.

7.8 Deleting a Data Series :

A chart is a collection of graphic objects. To access the objects, first select the chart. Then
click on the object you want to select. The selected object (data point, data series, title and so on)
will have hands. When an object is selected, you can delete or format the object.

1. In the chart, select the data series or any data point in the series.

2. Press the Delete key on the key board.

7.9 Modifying and Formatting Charts :

The chart area is a rectangular area within the chart window bounded by the chart border.
Chaning the size of the chart window changes the size of the chart area. All objects in a chart must
be within the chart area. The plot area is bounded by the axes and contains the columns, lines,
edges, or other objects used to represent the data points. Objects within the plot area have fixed
locations and cannot be moved or individually sized. For example, the X-axis lables must be lo-
cated near the X-axis. You can, however, resize all the objects in the plot area by increasing or
decreasing the plot area itself. Objects outside the plot area and axes can be sized or moved to
other locations in the chart area. The title and legend can be placed above, below, or in the plot
area. Any object in a chart can be selected and then formatted or deleted, with the exception of
individual data points. Data points can be formatted, but only data series can be added or deleted.
To select a data point, first select the data series, and then click once on the data point.

7.10 Using the Chart Tool Bar :

Common formatting options are available on the chart tool bar, as indicated in fig. 6.7. To
display the chart toolbar, right click any toolbar, and click chart. Select the chart object you want to
format from the chart objects dropdown list, and then use the toolbar buttons to format the object or
the entire chart.
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See the above Table 7.7 : chart ToolBar Buttons.

Double-click on any object to
open the formatting dialog box for
the object. For example, double-
clicking any column in a data se-
ries opens the Format Data Series
dialog box, shown in Fig. 6.8.

See the Figure 7.8: The
Format Data Series dialog box.

There are five or six pages
in this dialog box. Each contains a
group of settings for the seleted
data series. Depending on the
chart type, the dialog box may in-
clude a tab for shape and not in-
clude Axis or Y Errror Bars tabs.

Patterns : Used to
set the
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color and pattern for the series.

Axis : If the chart has more than one series, this option allows you to add a sec-
ond vertical axis at the right end of the plot area scaled to this data series.

Y Error Bars : Adds a graphic display of the standarded error; used to approximate sam-
pling error when the data in a chart is a statistical sample being applied to a
larger population.

Data Labels : Adds a descriptive label or the numeric value for each data point in the
series.

Series Order : Allows you to reorder the series in a chart, this is especially helpful with 3-
D charts, in which the selected range is charted in reverse order.

Options : Setting for the bar or column overlap, gap and color variation.

For more information on a specific control within the Data series dialog box, click the dialog
box Help button, and then click on the control.

Similar options are available when you double-click a selected data point, the plot area, chart
area or other chart objects.

You can select any object or series, right click, then select Format from the shortcut menu.
Chart type is always a shortcut menu option giving you access to all the types and subtypes. If the
entire chart is selected, chart options appears on the menu.

1. Select the Chart

2. Double-click on the object you want to format, or select the object, right-click, and choose
Format.. to open the appropriate dialog box.

3. Change formatting options and then click o.k to apply the changes and close the dialog
box.

7.12 Inserting and Formatting Titles :

If you decide to insert a title, select the chart, right-click and open the chart options dialog box
from the shortcut menu to open the titles page of the dialog box. You can edit or format existing titles
in a selected chart without having to use the chart options from the shortcut menu. To change the
text in a title, click once to select the title and then edit the selected text.

To wrap a title into multiple lines, place the insertion point where you want the second line to
begin, hold the ctrl key, and press Enter.

Double click on a title or select the title, right click, and choose Format Title from the shortcut
menu to open the Format chart Title dialog box. Use the controls in the patterns, Font and Alignment
Pages to format the title as you would format other text.

To change all the fonts used in a chart, double click in the chart area and change fonts in the
Format chart Area dialog box.

7.12 Exploding Pies :

If you want to emphasize specific data points in a pie chart, you can explode the pie chart by
moving one or more pieces of the pie further from the center Fig 6.9. Usually, you will move one or
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two individual slices to emphasize specific data points in the chart. In Fig 6.9, the Delhi slice has
been exploded. Although you can select an exploded pie in the chart wizard, the wizard explodes all
slices of the pie or the first slice, depending on which explosion sample you choose. It is easiest to
create an unexploded pie of the type you wish and then edit the chart to explode select slices.

Exploded Pie Chart.

If you want to explode all the slices in an existing chart, select the chart and then select the
Pie in the plot area . Excel will put handles on the outside edge of each slice of the pie. Drag any
slice away from the center to explode all the pie slices. To explode a single slice, first select the
chart, and then click on the pie to select the data series. With the series selected, click to select the
slice you want to explode, Drag the slice away from the center. When you explode all slices in a pie,
each slice gets smaller as you increase the space between the slices. If you explode slices indi-
vidually, the other slices remain centered in the plot area and the slices don’t get smaller.

7.13 SUMMARY :

Charts are graphical representations of numeric data. Charts are constructed with Data points.
In Excel we can create a different types of charts.

7.14 MODEL QUESTIONS :

1. What are the different types of charts that can be created in Excel.

2. Explain the procedure to create charts

3. How can you move and size charts

4. Explain the method of Editing a chart

7.15 REFERENCE BOOKS :

1. COURTER MARQUIS - Office 2000. - B.P.B.Publications, New Delhi.

2. RON MANSFIELD - Working in Microsoft Office - Tata Mc Graw - Hill, New Delhi.
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LESSON - 8

AN INTRODUCTION TO FUNCTIONS

8.0 OBJECTIVE :

After going through this lesson the student can know the different functions of Excel.

STRUCTURE :

8.1 Introduction

8.2 Parts of a Function

8.3 Functions RequiringAdd-Ins

8.4 Help Function

8.5 The Function Wizard

8.6 Different Functions

8.7 Error Messages from Functions

8.8 Summary

8.9 Model Questions

8.10 Reference Books

8.1 INTRODUCTION :

Excel’s worksheet functions are power tools that help you perform complex computations.
Excel has hundreds of functions that facilitate engineering computations, manipulate text and do
much more. Excel offers over 400 macro functions. Now we deal only with worksheet functions.

Worksheet functions can often be used by themselves as stand-alone formulas, or they can
be built into more complex formulas of your own creation.

Some functions inspect things and take action based on what they find. For example, the
function is NON TEXT (=) can check a cell and tell you, if the cell contains text or not other functions
convert things. The text function lower ( ) converts text to all lowercase, for instance, the engineer-
ing function CONVERT ( ) transforms values from one unit of measure to another (Fahrenheit to
Celsius, feet to meters and so on.

8.2 PARTS OF A FUNCTION :

Functions consists of function names and usually, arguments. For instance SQRT is the
function name, while the value (the positive number being evaluated is the argument. Arguments
can be values, references or names. They can also be text, logical values (True and False) or
arrays. A function’s syntax is illustrated by listing in the documentation, as well as in Excel’s Help
windows, all the function’s argument names in the order they should be used. For example you
might see the functions and their arguments expressed as :
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SQRT (Number)

or

SUM (Number 1, Number 2)

or

FV (Rate, Nper, Pmnt, Pv, Type)

Notice that in the FV example some of the arguments are bold face and others are not. This
is how some documentation differentiates between required and optional arguments. Often if you
don’t provide an argument, Excel uses the default argument for that function. For instance, the
function DOLLAR (number, decimals).

Converts numbers into text with dollar signs and optionally decimal places for cents or pen-
nies. The expression

= DOLLAR (10)

Would yield $. 10.00 (Notice the default decimal Point and two places for pennies even though
no second argument was supplied). The expression

=DOLLAR (10,1)

would create the text string $ 10.0 and = DOLLAR (10,)

Would yield $ 10 (neither decimal point nor pennies). In the first case, leaving out the optional
second argument and the comma that separates it causes Excel to use the default argument (a
decimal point and two places, in this case). In the second example, the comma separates the
second argument, which specifies the number of decimal place (1). In the third example, where
there is a comma and no second argument, the comma suggests to Excel that there is a second
argument (an argument specifying neither decimal point nor decimal places). The lesson here is
that commas are important in functions, and that sometimes there is a big difference in the results
if you delete a comma instead of leaving it and not entering an argument after it.

You can frequently use other functions as arguments. For instance you could combine the
ROUND and SQRT functions to compute the square root of a number, then round the results. The
formula

= ROUND (SQRT(A1),2)

would compute the square root of the contents of cell A1, then round the answer to two

decimal places.

8.3 FUNCTIONS REQUIRING Add - Ins :

Some functions require an add-in- additional software (such as a utility program) that is pro-
vided with Excel, but not automatically loaded when you run Excel. When you attempt to use func-
tions that require add-ins, Excel loads the add-ins automatically for you. For example, the BESSELI
Statistical function needs the Analysis Tool Pack. If Excel cannot load the required add-in, it may be
because you choose not to install add-ins when you initially installed Excel on your hard disk. Try
rerunning the installer program to add these features.
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8.4 ON-LINE FUNCTION HELP :

If each Excel function were described in detail here, the books size would double, and its title
would need to be changed to working with Excel’s Functions with an Appedix on Microsoft office,
Excel’s extensive on-line Help feature and the Function wizard will let you find and explore the

functions you are interested in

8.5 THE FUNCTION WIZARD :

Excel’s Function Wizard greatly simplifies the use of functions. It leads you through the nec-
essary steps, shows the results as you work and even provides examples of the functions in use.

1. Start by activating the cell where you want to paste the function.

2. Begin the formula with an
equal sign (=), and place the
insertion point where you want
to insert the function.

3. Click the Function wizard but-
ton on the standard toolbar, or
choose Insert / Function. The
Function Wizard’s step 1 win-
dow appears

See the figure 8.1 :

The wizard lists functions within the nine
categories mentioned earlier (Database, Date
and Time, and so on). In addition you will see the
Most Recently used and All options.

The key board shortcut for the function wizard is SHIFT + F3

4. Pick a category from the list on the left, then scroll in the list on the right to find the
desired function.

5. Click to pick the function, Its name is displayed in the Name box on the Formula
bar, and its name and arguments show near the bottom - left corner of the paste
function dialog box.

6. Read the wizard’s description of
the function to be sure its the one
you want.

7. Click the Next button and you will
see the second wizard dialog
box.

See the figure 8.2 :

Here you see list of arguments that are required and possibly some that are optional. The
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arguments are explained on screen and the Help button provides real-life examples.

Each dialog box is different and depends upon the function for its appearance and content.
For instance, SQRT has only one argument, while PV has many.

8. You can type directly in the wizard’s entry boxes or use your mouse to point to
cells containing the data you wish to use as arguments.

9. As you work, the wizard will show the results of its calculations in the value area
at the top right corner of the dialog box.

10. Click Finish when your formula is complete. As you can see in the following fig-
ure. When you click Finish, the wizard pastes the function into the active cell and
displays the results of the current arguments in the cell. You will see the equation
in the Formula bar.

See the above figure 8.3 :

8.6. DIFFERENT FUNCTIONS :

The following are some of the functions :

1. DATE AND TIME FUNCTIONS :

Some of the Date and Time functions simply return the current data and or time. Others do
date-and-time month. Let’s first look at a function that finds and reports the current time - the Now
() function when you use it, Now () inserts (returns) a new serial number corresponding to the
current date and time whenever the worksheet is recalculated.

For example, if you simply paste the formula = Now () into a cell, it will display the current
date followed by the current time, then update the cell’s contents every time the worksheet is
recalculated.

The actual appearance of cells containing the Now () or other Date and Time functions can
be changed by using different date and time types found in the Number tab of the Format cells
dialog box, reached by choosing Format 1 cells. For instance, Excel’s Date format will display date
and time in the format.
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m/d/yy h:mm

ENGINEERING FUNCTIONS :

Engineering functions are available, but require the Analysis Tool pack add- in macro, which

you will probably need to install manually if you did not opt to install it when you first installed office.

FINANCIAL FUNCTIONS :

Excel’s many financial functions are well documented with on-line Help. Many of them can be
used together, or can be included as arguments, one within the other.

Here is an example of one way to use PMT, Excel’s payment function. It will tell you what your
payments will be given the loan amount, number of payments and a fixed rate of interest. The
function’s syntax is

PMT (rate, Nper, PV, AV, Type)

This image illustrates PMT at work.

See the figure 8.4 :

Here rate is the interest rate per period. For
instance, if you borrow at an annual fixed interest
rate of 10.5% and then make monthly payments,
the interest rate is 10.5% divided by 12. That ex-
plains the division portion of the preceeding formula.

The argument nper needs the total number of payments. Thus, if you are borrowing for 30
years, and make monthly payments you will make 30 X 12 or 360 payments. PV is the present
value, or total amount that the series of payments is worth now - the loan amount in this case.
Notice that in the example the optional FV (future value) and type arguments were omitted. Future
value is a desired cash balance after the last payment is made type is either 0 (zero) or 1. Omitting
the type argument or entering 0 indicates that you will make payments at the end of each period.
Entering 1; on the other hand, tells Excel that the payments will be made at the beginning of the
period.

Related financial functions include FV, IPMT, NPER,
PPMT, PV and RATE as separate functions.

INFORMATION FUNCTIONS :

Some functions inspect things and report back. For
example, IS NON.TEXT () will let your formulas know if a
cell entry is not text. Other information functions can check
things external to Excel like the amount of RAM in your
computer, or which DOS version. Here is INTO ( ) at work.
Its syntax is INFO (type)

See the above figure 8.5 :

Cells B
2

through B
11

each have the same formula
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that refers to corresponding cells in column A, which contain the arguments that produce the re-
sults you see.

LOGICAL FUNCTIONS :

You use logic all the time. Chances are, you say things like “If the fruit at the market looks
good, please pick up some peaches or grapes, if grapes are less than a dollar a pound”. You can
use logic in Excel, too. Take the If function demonstrated in Figure 17.2. Its syntax is IF (logical, test,
value_if_ true, value_if_false)

In this example, the If ( ) function checks to see if the ending odometer reading is greater than
the starting reading. If it is not, chances are that the user has made a typographical error when
entering readings or perhaps the odometer

See the above figure 8.6 :

has reached its limit and “rolled over” to start again at zero. If the readings look okay, the If
function causes Excel to substract the beginning from the ending readings (B

s
- B

z
). If there seems

to be an error, the function displays text (check OD) in the cell.

LOOK UPAND REFERENCE FUNCTIONS :

Like explorers, lookup and Reference functions go to places that you send them and return
with answers. They can be used to create invoices that look up and insert different unit prices
based on quantities purchased, for instance, these features can inspect rows, columns or arrays.
Here is a simple example.
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See the below figure 8.7 :

The INDEX ( ) function here has been asked to go to the array bounded by cell addresses A1
through D4, then get the value stored in the cell two rows down and two columns across.

Look up and Reference functions can refer to ranges, names, specific cell addresses or row

and column counts.

MATHAND TRIG FUNCTIONS :

You have already seen several of the Mathematical functions in action - SQRT ( ) and SUM (
), for example. There are many others, Math and Trig functions. The Math and Trig functions can
refer to cell references, names or plain old numbers.

Two of the Math and Trig functions simply produce numbers whereever a worksheet recalcu-
lates. RAND ( ) Produces evenly distributed randum numbers greater than or equal to 0 (zero) and
less than 1 each time you recalculate - handy if you play the lottery or need to check probabilities.
The p1 ( ) function inserts 3.141592654.

STATISTICAL FUNCTIONS :

Pollsters and statisticians will want to check out the many statistical functions, from AVDEV

( ) to ZTEST ( )

TEXT FUNCTIONS :

To manipulate or analyze strings of text in cells, use text functions. For example, CLEAN ( )
will strip away any nonprinting characters stored in a cell. UPPER ( ) converts text to all upper case
DOLLAR ( ) converts numbers to their spelledout dollar equivalents and formats them in currency

format.
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8.7 ERROR MESSAGES FROM FUNCTIONS :

When you misuse arguments in functions, you will sometimes see cryptic error messages
like “ Error in formula”, or a message like “# NAME ?” or “#NUM !” will appear in the cell.

CONTAINING THE FLAWEDARGUMENT :

It is common to get messages like these when you work with names or text strings as argu-
ments. Text strings must be enclosed in quotation marks, while names must not be in quotes. For
instance, suppose you are using a math function like SQRT. If you enter the formula argument
SQRT (SALES), Excel expects to be able to find a named numeric value or range of cells in your
worksheet called SALES. If it can’t, you will get the message “#NAME?” In the cell containing the
formula. If you do have a positive numeric value named SALES, the formula will use its contents as
the functions argument. If the value of SALES is negative, you will see the error message “#NUM!”
Suppose you accidentally enclose the name SALES in quotes, then try to use it as an arithmetic

argument.

8.8 SUMMARY :

Functions are complex ready-made formulas that perform a series of operations on a speci-
fied range of values. You can enter functions either by typing them in cells or by using the Function
wizard.

8.9 MODEL QUESTIONS :

1. What is a Function ?

2. What are the parts of a Functions.

3. Explain Function wizard

4. Explain Different Functions in Excel.

8.10 REFERENCE BOOKS :

1. COURTER MARQUIS - Office 2000. - B.P.B.Publications, New Delhi.

2. RON MANSFIELD - Working in Microsoft Office - Tata Mc Graw - Hill, New Delhi.

3. JENNIFER FULTON - Excel 97. - P.H1 Private Limited, New Delhi.

Dr. Ch. Suravinda.



LESSON - 9

WORKING WITH GRAPHICS IN EXCEL

9.0 OBJECTIVE :- After going through this lesson the student can know what is Clip Art ?

STRUCTURE :

9.1 Introduction

9.2 Importing of Graphics

9.3 Other Sources of Clip Art

9.4 Using the Insert Picture Command

9.5 Clip Art Gallery

9.6 Using the clip board to insert Art

9.7 Resizing Graphics with Mouse

9.8 Sizing and Cropping Graphics with the Picture Command

9.9 Creating a New Drawing

9.10 Pictures Versus Drawing Objects

9.11 Filling

9.12 Line Colors and Shades of Gray

9.13 Line Sizes and Arrow heads

9.14 Using frames to position objects

9.15 Positioning Framed items with a Mouse

9.16 Selecting and Deleting Framed items

9.17 Deleting or Changing Frame Border

9.18 Captions

9.19 Summary

9.20 Model Questions

9.21 Reference Books

9.1 INTRODUCTION :

Microsoft office actually comes with two art collections - one in the clipart subfolder and
another collection reached via the Clip Art gallery. You will see how to combine the two collections
later in this chapter. This chapter contains all you will need to start creating your own art and using
free or low-cost clip art.

9.2 Importing Graphics :

Like text, computer art can be stored in disc files. Different drawing packages, scanners and
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other graphics tools create files in their own formats. Word for windows comes with a number of
built-in translation utilities, called filters that can convert graphics from many sources.

9.3 Other Sources of Clip- Art :

If you do not have the time or inclination to draw your own art, you can purchase compatible
disks from mail-order firms and retail software dealers. Many companies distribute low-cost or

free shareware and public-domain clip-art.

9.4 Using the Insert Picture Command :

The easiest way to get looked on graphics is to import a picture are :

1. Start by creating or opening a document.

2. Place the insertion point where you want the picture to appear.

3. Choose Insert 1 Picture to bring up the dialog box shown in fig. 9.1.

4. Click preview to look at the pictures before you insert one.

5. Browse by scrolling until you see something you like.

6. When you find a nice graphic, click Ok to insert it.

7. Reposition and perhaps resize or otherwise embellish the image.

9.5 Clip Art Gallery :

The office Clip Art Gallery is reached from the Insert 1 object command. It offers categories of
art and some other features.

To use the Clip Art Gal-
lery :

1. Start by creat-
ing or opening a
document.

2. Place the in-
sertion point
where you want
the picture to
appear.

3. Choose Insert
1 object.

See the figure
9.1

4. When you see
the object dialog
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box, click the create New tab if necessary and then scroll or pick Microsoft Clip Art
Gallery.

5. Click Ok, you will see the clip Art Gallery dialog box shown in fig. 9.2

6. Browse by clicking on categories of interest and scrolling to view thumb nails or min-
iature copies of graphics in the gallery.

7. Double-click on a thumbnail, or click once on it and once on Insert to insert a full sized
copy of the image at the insertion point in your word document.

8. Reposition and perhaps resize or otherwise embellish the image.

You can add other images to the gallery by using the gallery’s Add pictures and update pic-
tures buttons in the organize dialog box shown in fig. 7.3 reached via the organize button.

9.6 Using the Clip Board to insert Art :

If you already have a drawing program that you use to create and edit artwork, it is easy to
copy your work to the clipboard and then paste it into a word document. Here are the steps :

1. Switch to or
run the drawing program.

2. Select the art
of interest.

3. Copy it to the
clipboard (Ctrl +C).

4. Switch to or
start word.

5. Move the in-
sertion point to the desired lo-
cation in your word docu-
ment.

6. Paste the
graphic with the Edit 1 Paste
command or Ctrl +V.

See the figure 9.2

9.7. Resizing Graphics with Mouse :

When you click on a graphic in a word document to select it, the picture will be surrounded by
a box containing eight handles -one in each corner and one on each side of the outline box, when
the mouse pointer touches of these handles, it will turn into a two-headed arrow.



Centre for Distance Education Acharya Nagarjuna University9.4

See the below figure 9.3 :

To increase or decrease the size of the entire graphic, drag a corner handle diagonally, re-
leasing it when you are happy with the size.

To stretch a dimension, use the handles on the edges of the graphic outline to stretch the
graphic, as shown in Fig. 7.4 use undo if you are unhappy with the results.

To hide a part of a document hold down SHIFT while you drag any of the handles to create the
desired effect. The mouse pointer will turn into a square with a line through it.

To add space around a graphic, hold down SHIFT and drag handles away from the graphic.
Use undo to restore the original size.

See the below figure 9.4 :
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9.8. Sizing and Cropping Graphics with the Picture Command :

The Format 1 Picture command reveals the picture dialog box

See the above figure 9.5 :

It contains information about a selected picture’s original size and any cropping or resizing
that has been done. You can also use this box to specify new size and cropping dimensions. The
Reset button returns a graphic to its original size.

9.9 Creating a new drawing :

To create a new drawing using the word for windows drawing features :

1. Open a new or existing word document.

2. Place the insertion point where you want your new art to be inserted.

3. Click on the standared toolbar’s Drawing button, shown at left.

4. You will see the Drawing toolbar.

You can use a series of button, menu commands and your mouse to draw, resize, and
rearrange shapes, lines and text.

First click on a shape button or line button in the Drawing toolbar, and then use your mouse to
create lines or shapes. For instance, to create rectangles for an organizational chart, you would
click on the rectangle tool and drag with your mouse to create a rectangle of the desired shape and
size. Hold down SHIFT while dragging to create squares. To make a triangle, you would click once
to anchor the first point and drag to create the first side. Click again to anchor the second point and
drag again. Click to anchor the third point, and then drag back to the starting point and click one last
time to complete the triangle. Be sure not to hold down the mouse button when you are dragging. It
is very important to end the triangle where you began it.

To select rectangles or other drawing elements click on the arrow button at the top of the
drawing-tool stack, and then point to the item you want to move.
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Hold down SHIFT to select multiple objects. The Edit 1 select All command selects all text
and pictures. Selected objects are surrounded by small handles. Click outside of any selected
object to deselect all selected objects.

You can create text for drawings either in text boxes or in frames. Creating text in frames will
be discussed later in this lesson. To create a text box :

1. Click on the toolbar’s Text Box Button.

2. Drag the text box to the desired size and shape. Make it a little bigger than you think it
needs to be to accommodate the text you will type.

3. Type Marketing or any thing desired.

4. If necessary, you can increase the size of the text box by dragging, just as if it were any
other graphic object.

Text in boxes is automatically surrounded by lines unless you eliminate them. You will learn
how to do so later in this lesson.

You can make the text bold, center, change type styles and so on with the help of Format
toolbar.

To increase or decrease the space between the text and text box lines :

1. Select the text box

2. Choose Format 1 Drawing object.

3. Select the size and position tab.

4. Specify a new internal margin by typing a new setting in the appropriate box or by using
the up and down scroll arrows.

See the above figure 9.6 :

To eliminate the lines surrounding the text box :
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1. Select the box or boxes by clicking or SHIFT + clicking.

2. Use the Drawing toolbar’s line color button to reveal the line color palette.

3. Click on none at the top, as show here.

See the above figure 9.7 :

To move objects, follow these steps :

1. Select the item or items to be moved.

2. Point to one of the selected items with your mouse pointer avoiding the object’s handles.

3. The pointer will change, now looking like an arrow with four heads.

4. Drag with your mouse and watch an outline of the objects proposes a new location.

5. Release the mouse button to complete the move.

Word’s drawing features has optional invisible gridlines that make it easy to align objects.

Sometimes you will want to turn multiple drawing parts into a single object. This makes it
easier to move and resize complex elements. Simply select all of the elements of interest by SHIFT
+ clicking, and then use the group button on the Drawing tool bar.

Only elements of drawings can be grouped and ungrouped and not drawings.

Once you have created an object, you can select, copy and paste it to save time. Consider
grouping complex collections of lines and shapes and text before duplicating them.

9.10 Pictures versus Drawing Objects :

There are two general types of graphic images - drawing like the ones created and discussed
in this chapter and “pictures” or “painted” images created with paint programs. Drawing are made
up of individual elements-lines, circles and so on. Painted images are generally treated as one
large collection of dots. Files that end with the extension. BMP are bitmap “paintings”. So are many
windows metafiles (.WMF). Word can use both drawings and bitmaps; but if you want to edit them,
you must do so in a special window. Suppose you want to change the color and shading of the
ornament 1.wmf fine in the clipart folder. Here are the steps :
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1. Position the insertion point where you want the graphic to appear in your word docu-
ment.

2. Choose Insert 1 picture and locate the desired file ornament 1.Wmf, as shown in fig.
7.5.

3. Click OK to insert the graphic. It will appear in word document, but most of the Drawing
toolbar buttons won’t work. You can confirm this by watching the status area as you
point to the various buttons.

4. Double-click on the graphic to open a picture window. You will see the graphic, a picture
boundary and a small dialog box :

5. If the graphic is not surrounded by the picture boundary, click on the Reset Picture
Boundary button to move the picture into the boundary as shown in the following illus-
tration.

6. Edit the picture, SHIFT + click to select all elements and use the Fill color button on the
Drawing toolbar to choose 20% gray, as illustrated here :

See the above figure 9.8 :

7. When you have fin-
ished editing, click
the close Picture
button in the little
picture window.
The edited graphic
will be placed in
your word for win-
dows document at
the insertion point.

See the figure 9.9 :

To rotate or flip objects,
select them and use the Flip
Horizontal, Flip Vertical and Ro- tate Right buttons on the Drawing toolbar. You
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note, these buttons won’t work on text boxes.

You can use callouts to label graphics in word for windows documents. Here are the steps :

1. Create or import a graphic

2. Click the call out button, on the Drawing toolbar.

3. Click where you want the callout arrow to point.

4. Drag to where you want to position the text, and then release the mouse button. The
callout will appear.

5. Type any text you want to show in the callout,
and then select the text and change its ap-
pearance if you like.

6. Select the callout box and resize it if you wish.

7. Drag the box and line as desired to reposi-
tion them.

8. To change the design of the callout box. Use
the callout Defaults dialog box, shown here,
Reach it with Format callout button, shown
at left.

See the figure 9.10 :

9.11 Filling :

To fill drawn items with different colors or shades of gray, follow these steps.

1. Select the desired items.

2. Choose the button shown at left from the Drawing toolbar to bring up the Fill color
palette.

3. Click to select the desired fill color.

9.12 Line Colors and Shades of Gray :

To change the color or shade of lines :

1. Select the desired items.

2. Choose the button shown at left from the Drawing toolbar to bring up the line palette.

3. Click to select the desired line color.

9.13 Line Sizes and Arrow heads :

To change the size of lines and arrow heads :
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1. Select the desired lines.

2. Choose the button shown at left from the Drawing tool bar to bring up the line palette.

3. Click to select the desired line color.

4. Choose more to bring up the line tab in the Drawing Defaults dialog box, illustrated here

.

See the above figure 9.11 :

9.14 Using Frames to Position Objects :

If you simply paste a graphic into a word for windows document without framing it, it is treated
like a character. You can place the graphic between characters, move it from one line to another,
copy it, delete it and so on. To have maximum control over graphics and other document elements,
place them in frames.

Frames can contain either graphics, text or both.
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See the above figure 9.12 :

To use frames, you create them, insert objects into them, and then size and position them
either with your mouse or with the Frame dialog box. Normally, you will want to work with framed
items in page layout view or print preview so that you can easily see and move them.

You can either insert an empty frame and then place something in it, or you can select some-
thing and frame it. In either case, you use the insert 1 Frame command or the Insert Frame button,
shown at left. The following are the steps for creating a new, empty frame :

1. Start by switching to page layout view if you are not already in it.

2. Click the Drawing toolbar’s Insert Frame button or choose Insert 1 Frame.

3. Your pointer will change to a cross hair. Drag to create a frame of the approximate size
and shape you desire, located about where you want it to be placed.

4. Shortly after you release the mouse button, you will see a frame surrounded by a bor-
der. If you have the Show / Hide Paragraph feature enabled, you will see a paragraph
symbol within the frame and an anchor outside of it.

5. You can type text in the resulting frame paste things from the clipboard or use one of
the Insert menu commands, such as the picture and object commands.

If you already have something in your document that needs framing, you can do so by follow-
ing these steps :

1. Switch to page layout view if you are not there already.

2. Select the item or items to be framed.

3. Use either the Frame button on the Drawing toolbar or choose Insert 1 Frame.

4. Your selected items will be surrounded by a frame and you will see a paragraph symbol
and an anchor, as illustrated here, if you have clicked the show / Hide button.

Framed items and their frames can be resized just as you resize graphics.

9.15 Positioning Framed Items with a Mouse :

The simple way to position frames is to drag them with your mouse while in page layout view
or print preview follow these steps :

1. Place the pointer anywhere within the frame and watch the pointer.

2. The pointer will change to include a four headed arrow.

3. Press down on the primary mouse button and drag the frame to the upper-left corner of
the text.

4. Release the mouse button.

5. Soon after you release the mouse button, the frame will take up residence in its new
location. Text will move out of the way for the frame and the anchor icon will also move.
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To Edit the document you will need to click on the Magnifier button in Print Preview first.

When you add or delete text in your document, the framed item stays with its paragraph. A
frame always appears on the same page as its paragraph. This is often the desired effect. But if
you want to keep a framed item on a particular page, or a specific distance from a particular para-
graph it can be done with the Frame Dialog Box.

See the above figure 9.13 :

When you select a frame and open this dialog box, you will see the current size and position
of the frame. You can specify new size and position settings for the frame in inches (in), Centime-
ters (cm), Point (pr) or Picas (pi). You can change the units of measurement by using the General
tab in the options dialog box (reached by choosing Tools 1 options).

With Frame dialog box you can force a frame to always remain in the exact horizontal and
vertical center of a page, even when you change margins or page sizes or you can tell word for
windows to keep a frame a specified distance from margins or columns and you can anchor a
frame to text, so when the text moves, the frame accompanies it. Place a check mark in the Move
with Text box to accomplish this.

Frames and text can be used together several ways. Besides framing text, you can position
frames relative to text around frames. Here are a few ways to work with frames and text.

1. Placing Text in Frames :

You can use frames as small text windows that can be moved anywhere in your document.
If the move with Text option is checked in the Frame dialog box, the heading will stay with their
paragraphs when your document is edited.

2. Inserting Text in Framed Graphics :

If you want to add a caption to a framed graphic, select the frame and then press ENTER.
You will see a new paragraph mark in the frame. Type the caption. The caption will stay with the
frame when you move it.
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9.16 Selecting and Deleting Framed Items :

Its possible to delete frames and their contents simply by selecting the frame and then cutting
(CTRL + X) or pressing DEL (Select a frame by pointing and clicking with your mouse. Eight dark
black handless and a black line will appear around the frame when you have selected it).

To remove a frame but not its contents, select the frame and click the Remove Frame button
in the Frame dialog box (Choose Format 1 Frame). If you use this method to remove a frame with
a printing border but not its contents, the frames border will remain. Delete it or change it as de-
scribed next.

9.17 Deleting or Changing Frame Borders :

Frames are created without printing borders, but these can be added and altered.

1. Select a framed object in Page Layout view by clicking on the object.

2. Use the Format / Shading Command to add, change, or remove the border. For in-
stance, clicking on the None icon in the preset area of the Border dialog box removes a
Frames border.

Repeating Framed Items on Multiple Pages :

To repeat the same framed objects on multiple pages, create them in headers or footers.

9.18 Captions :

If you write long documents with numbered figures, tables and other elements you will have
done this new feature. It automatically numbers things, lets you label them, and then renumbers
them if you move them or otherwise change their sequence in a document. There are a variety of
display options, as well.

9.18.1 Adding Captions :

You can either manually caption the occasional item or turn on automatically captioning.

To manually caption :

1. Select the item to be captioned.

2. Choose Insert / Caption.

3. You’ll see the caption dialog box.

4. Word proposes a caption label that you can accept as is or edit, For example, you can
type descriptive text.

5. You can change the default appearence options by visiting the position list or the Cap-
tion Numbering dialog box.

6. Click Ok to insert the label. Be patient; it takes a moment.

To automatically add captions to items of a particular type (all drawings for instance), use the
Autocaption dialog box, reached with the Auto caption button in Caption dialog box. Word for win-
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dows can recognise and automatically caption the following types of files :

* Most Graphic Files

* Microsoft drawings

* Microsoft equations

* Microsoft Graphics

* Microsoft Word Art

* Inserted Word Documents

* Paint brush pictures

* Sounds and much more.

The automatically caption items, follow these steps :

1. Choose Insert / Caption.

2. Click Auto Caption.

3. Pick a type of item to automatically caption, you can pick more than one type for the
same caption label (for instance, you can Pick Microsoft drawings and word pictures).
Inserting either will have the same effect.

4. Pick a label type from the use label list or create your own with the New label button.

5. Pick a position for the label (above or below the item).

6. Change the numbering scheme if you like.

7. Repeat step 3 through 6 for each different type of caption you want.

8. Click Ok.

After you’ve turned on Auto Caption and defined the apperance options, words for windows
will automatically label any insertion that meets the Autocaption criteria.

When you move a figure and its label, word will not immediately update the figure labels. But
it will update figure number whenever you ask to print or switch to Print Preview. To force an imme-
diate update, select all of your text (CTRL + A) and Press F9.

To revise a Caption, just edit it like any other text to change all of the captions of a given type
(“Figure” to “FIG”, for instance), select a caption in text, visit the caption or Autocaption dialog box,
and pick a different label from the use label list.

To create a new label type (“FIG, for example), use the New label button in the caption and
Auto caption dialog box.

Including chapter and other Numbers in Captions :

You can include chapter and similar numbers in automatic captions if you like. Here are the
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steps :

1. Format all of the main headings (chapter, for example) as Heading style 1.

2. Choose Format / Heading Numberings. Make sure a numerical numbering style is in use
(not chapter one for instance).

3. Visit either the caption or Autocaption dialog box.

4. Choose the Numbering button.

5. When you see the Caption Numbering dialog box, choose Include chapter Numbers.

6. Back out by clicking Ok as needed.

9.19. Summary :

Like text computer art can be stored in disk files with Microsoft Excel we can create and edit
art work. It can be copied to the clipboard and then paste it into a word document.

9.20. MODEL QUESTIONS :

1. What is Clip Art ?

2. Explain Insert Picture Command.

3. Explain Picture Command.

4. How can you use frames to position objects ?

5. Explain the procedure of selecting, Deledting and changing Framed items and Frame
Border.

6. How can you use graphics in Excel ?

9.21. REFERENCE BOOKS :

1. COURTER MARQUIS - Office 2000. - B.P.B.Publications, New Delhi.

2. RON MANSFIELD - Working in Microsoft Office - Tata Mc Graw - Hill, New Delhi.

3. JENNIFER FULTON - Excel 97. - P.H1 Private Limited, New Delhi.

Dr. Ch. Suravinda.



LESSON - 10

INTRODUCTION OF EXCEL’S COMMAND
MACROS

10.0 OBJECTIVE :

After going through this lesson the student can know what are Macros ? Which are one of the

powerful features of word.

STRUCTURE :

10.1 Introduction

10.2 Recording Macros

10.3 Running Macros

10.4 Assigning Macros to Buttons

10.5 Summary

10.6 Model Questions

10.7 Reference Books

10.1 INTRODUCTION :

A Macro is a series of word commands grouped together as a single command to make
everyday tasks easier. Macros are recorded as instructions in word’s macro language, word Basic.
Just as Microsoft word lets you create macros to automate repetitive tasks, Microsoft Excel will
record and play back command macros. When you record a series of steps, Excel converts your
work into Visual Basic - a computer programming language that describes what you have done.
You can then save this information as named macros and run it whenever you wish.

There are several ways to run macros. You can assign keyboard shortcuts to macros. You
can even create macro buttons or place mac-
ros on menus.

10.2 Recording Macros :

Following are the steps to create your own
macros.

1. Start by practicing what you intend
to do a few times so you know
what steps to take and are assured
that they will work.

2. When you have finished rehears-
ing, choose Tools / Record Macro
/ Record New Macro. You will see
the Record New Macro dialog box;
Click the options button to see the
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“big” version of the dialog box.

See the above figure 10.1 :

3. Excel will suggest a macro name that you will probably not like. Type a new name if you
wish. Macro names must start with a letter, cannot contain spaces and should not look
like a reference. In place of spaces use, an underline character (-).

4. Add a note in the Description box if you like, it will help you remember what the macro
does.

5. Decide where to save your macro - in the current workbook, a new work book, or
a personal collection of macros.

6. Excel proposes a key board shortcut that you can use in combination with CTRL
and sometimes SHIFT to execute macros.

7. You can also add the Macro to your Tools menu by checking the Menu Item on
Tools Menu choice and typing a menu item name in the menu item box.

8. Once you have named the Macro, chosen a key combination for it and told Excel
where to store the macro, click ok to begin recording.

9. Live it up / check, drag, format, enter text or values, construct formulas, use func-
tions and so on. When you have finished, click the stop Recorder button shown
here.

See the above figure 10.2 :

10.3 Running Macros :

Once you have recorded a Macro, use either the key board shortcut, the Tools menu
choice if you have added one, or the Macro command on Excel’s Tools menu. If you use the
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keyboard shortcut, it will run immediately. The Macro command provides a list of macros.

Pick the one you want-either double click on it or click once to select and once on Run.

10.4 Assigning Macros to Buttons :

If you have a favourite Macro or you want to make a complex task easy for other users,
consider creating Macro buttons.

The Process is as follows :

1. Start by displaying the Drawing tool bar. (Use Excel’s Toolbars command on the
view menu or the Drawing button on the standarded toolbar).

2. Click the create button.

3. When you click on the button tool, your pointer turns into cross hairs. Drag to cre-
ate a button large enough to contain a descriptive label.

4. When you release the mouse button you will see a rectangle like the one shown
here. The box will contain the word “Button”.

5. Excel will then present a list of macros, pick the one you want to assign to the
button (double click on the macro’s name in the scrolling list.

6. Click on the button name and change it to something meaningful.

Click on the button to run your macro. To move, resize, or otherwise change a button
without running the macro, hold down CTRL when you point to the button. The button will take
on a by-now-familiar outline that will remind you of a graphic. You can reposition a selected
button by dragging with the pointer shaped like an arrow head. You can edit the button’s size,
shape or name by holding down CTRL while you click on the button. Use Excel’s formatting
commands and tools to change the buttons font, type size, style and other text attributes. Drag
the button as you would any other graphic object to change its size and shape.

To delete a button select it (CTRL - Click) and then use DEL or the Edit menu’s clear
command. Deleting a button does not delete the macro that it is assigned to. To delete the
macro open the Macro dialog box, reached with Tools / Macro, select the macro to be deleted
and click the Delete button.

Paste Due

Button
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The Instructions look like for a macro is as follows :

See the above figure 10.3 :

10.5 SUMMARY :

A group of commands can be put in a single command by way of Macros. Excel will
work and play back command Macros.

10.6 MODEL QUESTIONS :

1. What are Macros ?

2. How can you record Macros ?

3. How can you Run Macros ?

10.7 REFERENCE BOOKS :

1. COURTER MARQUIS - Office 2000. - B.P.B.Publications, New Delhi.

2. RON MANSFIELD - Working in Microsoft Office - Tata Mc Graw - Hill, New Delhi.

3. JENNIFER FULTON - Excel 97. - P.H1 Private Limited, New Delhi.

Dr. Ch. Suravinda.



LESSON - 11

USING WORKSHEETS AS DATA BASES

11.0 OBJECTIVE : After going through this lesson the student can know How to use

worksheets as Data bases.

STRUCTURE :

11.1 INTRODUCTION

11.2 DATABASE CONCEPTS AND TERMS

11.3 CREATING AN EXCEL DATABASE

11.4 WORKING WITH DATA FORMS

11.5 FILTERING

11.6 SORTING EXCEL DATABASES

11.7 CROSS - TABULATING DATABASES

11.8 ADDING SUBTOTALS TO DATABASES

11.9 SUMMARY

11.10 MODEL QUESTIONS

11.11 REFERENCE BOOKS

11.1 INTRODUCTION :

Excel has a number of database features. You can use these features to manage a print
merge mailing list, to control your inventory or to do a statistical analysis of complex option sur-
veys.

11.2 DATABASE CONCEPTS AND TERMS :

You need to know several database terms for better understanding of this lesson. Some
worth knowing terms are as follows.

1. DATABASE RANGE :

Even though your database might be a small part of a larger worksheet. Excel will often
automatically define likely database ranges, like cells A2 through E8 in Figure 9.1.

2. RECORDS AND FIELDS :

Excel treats the contents of each row of a database range as a record. In figure 9.1, row 4 is
Rambo’s record row 5 is plulo’s record and so on. The first row of any database range must
always contain column labels, which Excel will use as database field names. These field names
can contain spaces. The field name Annual salary would be permitted.
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See the above figure 11.1 :

Microsoft calls each column in a database a field and individual cells in a database are also
referred to as fields. You can enter text, numbers, dates, functions and formulas in cells. When a
field contains a function or formula it is referred to as a computed field. For Instance, if you had a
quantity order field and a unit price field, you can create a Total cost field containing a formula that
computes total cost based on the other two fields.

11.3 CREATING AN EXCEL DATABASE :

When creating a database set up a separate field for any item you will want to refer to sepa-
rately. For instance, if you want to sort on first and last names separately, create a field for each.
This is particularly important to remember if you plan to sort on, or search for, things like ZIP
Codes.

Set column widths right at the start, or change widths after you have entered the data by
dragging or by using column width features.

11.3.1 ENTERING DATA:

You can enter, edit and format the data in a database just as you would any other Excel cell
contents or you can use Excel’s Data Form features. What ever the method you use there are
some cautions worth mentioning.

a) Excel does not let you specify “field types”, so it is possible to enter a number or text or
a data into any field. This can cause problems when entering numbers that you plan to
display and sort as text. For instance, Excel strips off leading zeros in numeric entries.
But some Zip codes start with zero. If you want to see those “leading” zeros in Zip
codes, you will need to enter each Zip code as text, not as a number. To do this, you
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must type an apostrophe before each Zip code - or any number you intend to enter as
text.

If you want Zip codes to sort the way you normally expect to see them, you will always need
to enter each Zip code this way.

b) Unlike fancier database products, Excel will not challenge you if you mix. text, numeric
and data entries. Usually, you can see if there is a problem by looking at the appear-
ance of the entries. For instance, unless you format them otherwise text entries in
cells will be left justified and general numeric entries will be right justified.

11.3.2ADDING RECORDS TO ADATABASE :

Normally you will add new records beneath the last record in your database. You can either
do this the way you add regular worksheet data or you can use a database form that prompts you
for data entries and automatically places new records beneath your last record.

It is also possible to make space for records in the middle of your data range, insert empty
rows, then make mid database entries. There are advantages and disadvantages to each of these
approaches. Excel will automatically accommodate the addition of new records if it can which
brings us to the second problem.

If you plan to have anything in rows directly beneath the database cells, you will be inconve-
nienced when you have more data than will fit in the previously defined data range. Suppose, for
instance, that in Fig. 9.1 you have placed a worksheet equation in cell B11, if you used the data
form to enter a new record, you get the message “cannot extend database”, since the data form
feature will not write over or push down cell contents.

In case where there is insufficient room to easily extend the database, either you can opt to
manually insert additional records mid-database. Pushing everything else down or you can insert
blank lines at the end of the database range to extend it. Check your worksheet for formulas that no
longer work as a result of your pushing things down this way.

You can also add fields to an existing database. For example, if you wanted to add a last
Name field in column F, you could simply type the field name in cell F2, then enter last names in
cells F3 through F8, if you decided to insert a last Name field between Name and age, by selecting
column B and using the Edit menu’s Insert command, Excel would extend the database range for
you.

11.4 WORKING WITH DATA FORMS :

Data forms are handy for data entry, record viewing and searching. A data form is automati-
cally created whenever you choose the Form command on the Data menu you can see the form
by choosing Data 1 Form. As you can see from Fig. 9.2 data forms are dialog boxes containing field
names, text entry boxes and buttons.

Unfortunately, it is possible to design databases with so many fields that they won’t all the
visible on your form. You cannot scroll to overcome this and, if you place multiple-line entries in
fields by using the old CTRL + ENTER trick, you will only see the first line of those entries in your
form.
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Use the scroll arrows to view different records. Enter the edit text in the data form’s text
boxes as you had expect. You can use TAB to move from text box to text box in your data form
SHIFT + TAB moves you backward.

See the above figure 11.2 :

Adding and Editing Records with the Data Forms :

To add a new record with the data form, click the New button or scroll to the last record,
which should be empty. Type as usual, making sure you put the right data in the right fields. Feel
free to leave fields empty.

To edit records using the data form, scroll to the record of interest and edit in the text boxes
using standard windows techniques (select and change). Computer fields cannot be edited. You
cannot format text in the data form (the Bold and Italic toolbar buttons won’t work here ). Instead,
format text in the worksheet itself.

Changes and additions made in the data form are not reflected in the database until you
move to a different record or close the data form. Even when changes have been made in the
database, they reside only in your computer’s RAM until you save the worksheet.

Deleting Records with the Data Form :

To delete a record with the data form, bring the record into view and click the data form’s
Delete button. You will be asked to confirm the deletion. You cannot undo deletions performed from
the data form. To delete multiple records it is usually best to round them up with Auto Filter and then
to delete the records found.
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SEARCH CRITERIA:

You can use the data form to create and then scroll through collections of records that meet
specific criteria for instance, all the women earning more than Rs. 40,000, start by choosing the
criteria button in the data form. You will see a dialog box like figure 9.3.

In this example, Excel will gather up just female employees who earn in excess of Rs. 40,000.
Notice that Rs. Signs and commas are ignored, so you only need to enter > 40,000 for the salary
criterion.

See the above figure 11.3 :

11.5 FILTERING :

Excel offers a powerful database function that is a big improvement over the search criteria
method just described. It comes in two flavours - Auto Filter and Advanced Filtering. Let us now
learn the Auto Filter now.

When you choose Data / Filter / Auto Filter, Excel Zips through your data base looking for
each unique entry in each column. For example, in
the sample database it would find four unique de-
partments in the Dept column - Admin, sales ship-
ping and production. In the sex column it would find
two unique entries - Male and Female. It does this
for each column and creates dropdown lists for each
column, like the one shown here.

See the above figure 11.4 :

The lists contain all the unique values for the column plus the choices (All), (Top 10), (Cus-
tom), (Blanks) and (Non Blanks).
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When you drop down one of these menus and make a choice, Excel will filter (hide) all
records not containing the choosen value. For instance, if you choose sales from the Dpt column,
you will see only records that contain sales values in their Dpt field, as shown here. The other
records are not deleted, they are just temporarily hidden from view.

See the above figure 11.5 :

The choices (Blanks) and (Non Blanks) show records with either blank or nonblank entries,
respectively. In other words, choosing (Non Blanks) will display (not filter out) any records that have
something typed in the field.

The (All) choice filters nothing for that column. In other words, if you choose (All) in every
column, you will see all of your records. A less robust version of (All) is (Top 10), which filters out all
but the “topten” entries. For instance, you could filter out all but the top-ten highest salaries or ages.

You can combine filters, for instance, to find all of the males in the production department,
you could choose Male in sex and production in Dept.

There is one advanced filtering capability i.e. ‘custom’ choice in the drop-down menus, with it
you can specify ranges of things you want to see. For instance, to see all of the employees that
earn over Rs. 25000, you could.

1. Choose ‘custom’ from the salary drop-down list to bring up the custom Autofilter dialog
box.

See the above figure 11.6 :

2. Specify greater than by picking the > operator from the drop-down list;

3. Enter the amount

4. Click ok, Excel will filter out (hide) records for employees earning less than Rs. 25,000.
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SHOWINGALL RECORDSAFTER AUTO FILTERING :

There are two ways you can show all records after Autofiltering. If you want to leave the drop-
down lists in place for future use, you can display all your records by choosing Data / Filter / Show
All.

REMOVINGAUTOFILTER LISTS :

To remove the drop-down filter lists and display all of your records, choose the Autofilter
choice from the ‘Filter submenu a second time. This removes the check mark next to the menu
choice, deletes the drop-down menus, this redisplays all records.

11.6 SORTING EXCEL DATA BASES :

If you only have one database defined on your worksheet, sorting can be quite easy :

1. Activate any one cell in the field you want to use as the sort key (Age, in the example).

If you select a range of cells, rather than activating a single cell only those selected
cells will be sorted.

2. With either a single cell or everything you want to sort selected, click either the sort
Ascending or sort Descending button on the standard tool bar.

Excel will sort, leaving the labels at the top of the list where they belong. In the preceeding
example, the data will be sorted in descending order, based on employee’s age, resulting in the
oldest person being first in the database and the youngest at the end. You could just as easily sort
the list by department, using cell D3 as the key.

See the above figure 11.7 :

MULTILEVEL SORTS :

Suppose you had a bigger database and wanted to sort it by department to see staffers listed
alphabetically within their departments. You could do this in one pass by using the sort dialog box
(reached with the sort command on the Data menu)
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See the above figure 11.8 :

You would make Dpt the first sort key (Sort By) and Name the second sort they (Then By).
Pick names from he drop-down lists or specify cell addresses.

In a still more-complex database, if you have several people with the same names in the
same department. You could use age or sex as the tie-breaker by specifying one of those criteria
as the third sort key (Then By)

Incidentally, you can choose to sort by column instead of row, which is one way to rearrange
the order in which fields appear in your database. If you rearrange a database this way, be sure to
include the field names in the selection so that the names move with the data.

11.7 CROSS-TABULATING DATABASES :

How many women do we have in each department ? How do salaries break down by sex
around here ? If you ask, or are asked, questions like these, you may want to check out Excel’s
pivot Table wizard. With a minimum of groaing. You should be able to create cross tabulated tables
like this one.

See the above figure11.9 :

Complex cross-tabulation can also be performed on budgets and other large documents.

The pivot Table wizard is a big improvement over the crosstab wizard from earlier versions of
Excel. It is Quick and powerful. It seems more reliable than its predecessor, too. Just the same,
save your work before using pivot table wizard.
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1. After saving your work, click any where in your database.

2. Choose pivot table from Excel’s Data menu.

3. Specify a data source. (You can use your Excel Database or external sources)

4. Drag items in the pivot table wizard step 3 of 4 dialog box to set up the report. By default
the wizard counts things; but if you double-click on an item, you can choose other
actions such as totals. Fig. 9.11 shows a typical report and the settings that produced
it.

See the above figure 11.10:

Whenever you change data in your database, you will need to refresh the data. The easiest
way to do this is which the Refresh Data button on the Query and Pivot toolbar, which appears
when you are working with Pivot Table wizard.
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11.8 ADDING SUBTOTALS TO DATABASES :

While many wizards automatically create subtotals for you, Excel’s subtotals command on
the Data menu lets you add your own subtotals so any sorted list of data. Subtotals will be created
each time the data in a specified row differs from that in the row above. For example, you could sort
your sample employee database by department and get salary subtotals by department. Here are
the general steps for creating subtotals :

1. Sort the data in an order that will produce the subtotals you desire, this example sorted
on Dpt.

See the figure 11.11 :

2. Choose the column to be monitored for changes (Dpt in this example)

3. Choose the Function to be used (Sum for numeric subtotals or COUNT for counting
things).

4. Choose the columns you want to subtotal (salary in this example).

5. Choose the other appearance options you desire. The defaults are shown in this ex-
ample.

6. Click OK.

7. Reformat the columns if the subtotals exceed the old columns widths.

8. You should see subtotals that something like these.
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See the above figure 11.12 :

9. You can show or hide detail with the new outline controls that appear on the left of the
worksheet. For example, here, only totals and subtotals are displayed.

See the above figure 11.13 :

REMOVING SUBTOTALS :

To remove all subtotals, select the data of interest, and use the subtotals command on the
Data menu. Click on the Remove All button.

11.9 SUMMARY :

Excel has a numerous database features. You can use these features to manage print merge
mailing list, to control your inventory, or to do a statistical analysis of complex opinion surveys.

11.10 MODEL QUESTIONS :

1. Write down the Database concepts and Terms.

2. How can you create an Excel Database.

3. How can you add Records to an existed Database

4. Explain working with Data Forms.

5. What is Filtering ? How can it be done ?

6. Explain the Method of sorting Excel Database.

7. How can you cross Tabulate Databases ?
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8. How can you Add subtotals to Databases.

11.11 REFERENCE BOOKS :

1. Working with Microsoft Office - Ron Mans - field

2. Office 2000 - Gini counter, Annette Marquis

Dr. Ch.Suravinda.



LESSON - 12

AUTOMATING WHAT - IF - PROJECTS

12.0 OBJECTIVE :

After going through this lesson the student can know about scenario Management and finding
the Right Number with solver.

STRUCTURE :

12.1 INTRODUCTION

12.2 GENERAL ORGANIZATIONAL TIPS

12.3 SCENARIO MANAGER

12.4 FINDING THE RIGHT NUMBER WITH SOLVER

12.5 SUMMARY

12.6 MODEL QUESTIONS

12.7 REFERENCE BOOKS

12.1 INTRODUCTION :

Computerized spreadsheets can answer the questions.

To Answer the questions like “What are the effects of changing sales commission to 3 per-
cent, 2 percent or 4 percent” ? Or “What if Interest rate falls to 7.25 percent” ? We use computer-
ised spreadsheets. But the process of preparing them can be pretty tedious, particularly when you
are using multiple variables. Excel provides a number of features designed to speed up complex
what-if questions. They related reporting features. This lesson introduces you to these tools.

12.2 GENERAL ORGANIZATIONAL TIPS :

When you design worksheets that will be used regularly, it is a good idea to organize them
logically in a top down manner. Place introductory text and instructions at the top, followed by the
assumptions you will most likely want to change. Label them clearly. This makes it easy for other
people to see and understand your methodology.

Protect essential equations so that people donot accidentally overwrite them. Consider break-
ing complex formulas up into smaller, easier to understand parts that display helpful intermediate
answers, Test, Test some more, Test again.

12.3 SCENARIO MANAGER :

Scenarios are named sets of assumptions (inputs) and the resulting computations (results)
that you ask a worksheet to compute. For instance, suppose you wanted to explore the impact of
interest rates on mortgage payments and total interest paid. You might also want to see the effect
of borrowing for 15 rather than 30 years. Scenario manager can make short work of this and can
even create nice summary reports.
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DEFINING SCENARIOS :

Select or CTRL + Select the cells that you want to be able to change in the scenario. In the
following example, you want to be able to explore changes in interest rates, the number of pay-
ments and the loan amounts, so cells B2 through B4 have been selected. To select non adjacent
cells use CTRL + Click.

With the appropriate cells selected, choose Tools / Scenarios. You will see the scenario
Manager dialog box telling you that no scenarios have been defined yet. Click the Add button to
define some. You will see an add scenario box something like the one in Fig. 10.1

See the above figure 12.1 :

Create as many named scenarios as you want by typing distinct scenario names and differ-
ent values in the scenario values dialog box for one or all of the assumptions in each scenario Click
Add each time you want to save a scenario. The scenario values dialog box then pops up, letting
you adjust numbers based upon the original selection. If you want to add more scenarios, click Add.
When you have finished adding scenarios, click ok. You will again see the scenario Manager dialog
box.

See the below figure 12.2 :
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VIEWING SCENARIOS :

In the preceeding illustration, there are three possible scenarios for cells B2 through B4; 5%
Interest 30 years, 14% interest 30 years and 7% interest 15 years. To see the effect of a scenario,
select it from the list and click show. Your worksheet will reflect the chosen assumptions.

OBTAINING SCENARIO SUMMARIES :

It is also easy to obtain summary reports that show the assumptions for each scenario and
the results of each scenario. The following illustration is an example of this

See the above figure 12.3 :

Start by clicking the summary button in the scenario Manager dialog box. Excel asks you to
define the changing cells to be displayed. It proposes a range for you.

See the above figure 12.4 :

The proposed range usually contains formulas that refer to the changing assumption. You
can keep the suggested range or define your own. Click ok when you are satisfied with the results
range.

You can ask Excel to create a summary report or by clicking on the appropriate button, re-
quest a scenario pivot table.

Excel then creates and formats a report showing the various scenarios and their results.
Notice that scenario Manager labels rows with cell addresses as $B,$2, $B$3, and so on. For
naming the cells in worksheet use the Insert/ Name/ Define command. The names will appear in
the reports.
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See the above Figure 12.5 :

Notice also that Excel may not propose all of the result cells that you will want to see. You can
overrule the proposed range by entering your own.

CHANGING SCENARIOS :

Visit the Scenario Manager Dialog box to add, delete or edit Scenarios you cannot undo
scenario deletions.

12.4 FINDING THE RIGHT NUMBER WITH SOLVER :

Solver helps you find combinations that reach a goal. For instance, have you ever said, “If
interest rates are 7 percent, and I can afford monthly payments of Rs. 1000 a month, how much
can I borrow ? or to find the most profitable product mix, or examine sales commission scenarios
to find the mix that is most profitable ? Excel’s solver add- in program can assist you. Tell it your
goals, and it does backflips to help you reach them.

Suppose you know you can spend Rs.1000 per month for 360 months, and you know that
interest rates are 7% solver will help you determine the maximum loan amount.

1. Start by constructing and testing your model

See the above figure 12.6 :

2. When you know the model works right, save it

3. Choose solver from Excel’s Tools menu. Because it is an add-in, the command may
take a moment to load itself the first time you use it each session.

4. Soon you will see a solver parameters dialog box.
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See the above figure 12.7 :

5. Tell solver which cell you want to solve for. Then define the constraints, or the rules
to be used. For instance, you know you do not want to spend more than Rs. 1,000
per month, and you donot want solver to change the interest rates or number of
payments, so you must add constraints for all three items. Create each contraint
separately by using the Add button to build constrains like the one shown here :

See the above figure 12.8 :

Constraints can refer to cell locations or to names if you have defined them like Interest for cell B2.

6. When you have created all the appropriate constraints, use the solve button to search
for a solution. Eventually the hour glass that pops up will disappear. If your model
worksheet is in view, you will see a solution.

See the above figure 12.9 :
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and you will see a solver Results dialog box this one.

See the above figure 12.10 :

7. Choose Answer in the Reports list to see a report like the one in 10.8

Solver lets you view your solutions, change the rules and create reports. You can save solu-
tions for later reuse.

See the above figure 12.11 :

TO LEARN MORE ABOUT SOLVER :

This lesson illustrates a very simple solver example that admittedly could be accomplished
other ways. But is illustrates the concepts nicely. To see solver at work on a bigger problem, open
the solverex.xls worksheet found in your Excel / Examples / Solver subfolder.

12.5 SUMMARY :

Excel provides a number of features designed to speed up complex what -if questions. They
include the scenario Manager, What-if, add-in macros. Scenarios are named sets of assumptions
and the resulting computations that you ask a worksheet to compute. Solver helps you find combi-
nations that reach a goal.
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12.6 MODEL QUESTIONS :

1. How Excel help you to find answers for What-if ?

2. Write down general Organizational tips

3. What is Scenario Manager.

4. How can you find the Right number with solver.

12.7 REFERENCE BOOKS :

1. COURTER MARQUIS - Office 2000. - B.P.B.Publications, New Delhi.

2. RON MANSFIELD - Working in Microsoft Office - Tata Mc Graw - Hill, New Delhi.

3. JENNIFER FULTON - Excel 97. - P.H1 Private Limited, New Delhi.
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